This queue is for tickets about the CPAN CPAN distribution.

Report information
The Basics
Id:
27869
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
mschwern [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Wishlist
Broken in:
(no value)
Fixed in:
1.92



Subject: Look in META.yml for MakeMaker or Module::Build upgrade
Right now its difficult to impossible for a module to depend on a new version of MakeMaker or Module::Build. This is because dependencies are resolved after Makefile.PL / Build.PL are run. As a result new features of MakeMaker and Module::Build are very difficult to depend on. If CPAN would look in the META.yml for a requires or build_requires on ExtUtils::MakeMaker or Module::Build and immediately resolve that dependency, before running Makefile.PL or Build.PL, that would ease this problem.
I'm working on this. "configure_requires" was added recently to the meta yaml spec and it demands exactly that.
Subject: configure_requires support in META.yml
RT-Send-CC: module-build@perl.org
On Mon Jul 02 00:55:46 2007, ANDK wrote:
Show quoted text
> I'm working on this. "configure_requires" was added recently to the
meta
Show quoted text
> yaml spec and it demands exactly that.
http://search.cpan.org/src/ANDK/CPAN-1.91_54/Changes


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.