This queue is for tickets about the CPAN CPAN distribution.

Report information
The Basics
Id:
2781
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
ANDK [...] cpan.org
Requestors:
greg.hering [...] bench.com
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
1.70
Fixed in:
(no value)



Subject: CPAN ignores modules from default installation.
Perl: 5.8.0 CPAN: 1.70 OS: RH9 on intel and Solaris8 on sparc Situation: Run 'CPAN' module. Execute 'r' command. List of modules to be updated is displayed. Update all recommended packages. Execute 'r' command again. Several of the packages report same 'old' version. Do search in file system for packages. Multiple packages are discovered. One, for example, would be in /usr/lib/perl5/<module> and the other would be in /usr/lib/perl5/site_perl/<module> (or other more convoluted path which might include 'i386-linux-thread-multi' or 'sun4-solaris'). Removing the shorter path (from default install of perl?) usually works around the problem and shows all packages up to date. In one case (Unicode::Normalize I think) it was the longer path that showed the earlier version (using find . -name <module.pm> -exec grep VERSION {} \;). I think that the older version should be removed if the new version is not going to be installed in the same path.


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.