Skip Menu |
 

This queue is for tickets about the Compress-Zlib CPAN distribution.

Report information
The Basics
Id: 27598
Status: open
Priority: 0/
Queue: Compress-Zlib

People
Owner: Nobody in particular
Requestors: quanah [...] zimbra.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: XS version error from Compress:Zlib
Date: Fri, 15 Jun 2007 12:02:45 -0700
To: bug-Compress-Zlib [...] rt.cpan.org
From: Quanah Gibson-Mount <quanah [...] zimbra.com>
Download (untitled) / with headers
text/plain 591b
Please see: <http://www.perlmonks.org/?node_id=594914> This bug affects RHEL4 - Red Hat Enterprise Linux ES release 4 (Nahant Update 4) This is perl, v5.8.5 built for i386-linux-thread-multi We use CPAN to grab the latest modules and build them, which grabs 2.004 which makes downgrading to 1.42 difficult (though possibly manually). This bug has been around for half a year now, it would be great to see the fix. Thanks! --Quanah -- Quanah Gibson-Mount Principal Software Engineer Zimbra, Inc -------------------- Zimbra :: the leader in open source messaging and collaboration
From: PMQS [...] cpan.org
Download (untitled) / with headers
text/plain 795b
On Fri Jun 15 15:03:57 2007, quanah@zimbra.com wrote: Show quoted text
> Please see: > > <http://www.perlmonks.org/?node_id=594914> > > This bug affects RHEL4 - Red Hat Enterprise Linux ES release 4
(Nahant Show quoted text
> Update 4) > > This is perl, v5.8.5 built for i386-linux-thread-multi > > We use CPAN to grab the latest modules and build them, which grabs
2.004 Show quoted text
> which makes downgrading to 1.42 difficult (though possibly
manually). This Show quoted text
> bug has been around for half a year now, it would be great to see the
fix. Hi Quanah thanks for reminding me about this. I reviewed the mail thread and it sort of petered out without coming to a conclusion. To summarise the issue - the problem is my reliance on dualvar from Scalar::Util? If I included my own version of dualvar does the problem go away? Paul
Subject: Re: [rt.cpan.org #27598] XS version error from Compress:Zlib
Date: Mon, 18 Jun 2007 14:29:35 -0700
To: bug-Compress-Zlib [...] rt.cpan.org
From: Quanah Gibson-Mount <quanah [...] zimbra.com>
Download (untitled) / with headers
text/plain 1.8k
--On June 15, 2007 3:54:40 PM -0400 Paul Marquess via RT <bug-Compress-Zlib@rt.cpan.org> wrote: Show quoted text
> > <URL: http://rt.cpan.org/Ticket/Display.html?id=27598 > > > On Fri Jun 15 15:03:57 2007, quanah@zimbra.com wrote:
>> Please see: >> >> <http://www.perlmonks.org/?node_id=594914> >> >> This bug affects RHEL4 - Red Hat Enterprise Linux ES release 4
> (Nahant
>> Update 4) >> >> This is perl, v5.8.5 built for i386-linux-thread-multi >> >> We use CPAN to grab the latest modules and build them, which grabs
> 2.004
>> which makes downgrading to 1.42 difficult (though possibly
> manually). This
>> bug has been around for half a year now, it would be great to see the
> fix. > > Hi Quanah > > thanks for reminding me about this. I reviewed the mail thread and it > sort of petered out without coming to a conclusion. > > To summarise the issue - the problem is my reliance on dualvar from > Scalar::Util? If I included my own version of dualvar does the problem > go away?
Hi Paul, I asked Gaal about this and he said: Hi Quanah, On 6/18/07, Quanah Gibson-Mount <quanah@zimbra.com> wrote: Show quoted text
> I filed bug <http://rt.cpan.org/Public/Bug/Display.html?id=27598> with the > Compress-Zlib author, and the author is curious to know the best way to > proceed with fixing it. I thought you might have some ideas.
As far as I recall, the problem is that one stage of the PAR build process has no access to XS. So no, implementing dualvar instead of relying on the one in Scalar::Util, because (presumably) the alternative version won't be loadable either. Unless there's a clever way to write it in pure Perl, but I can't think of one. I no longer have a Red Hat based system to try this on, unfortunately. Good luck though! -- Gaal Yahas <gaal@forum2.org> http://gaal.livejournal.com/ -- Quanah Gibson-Mount Principal Software Engineer Zimbra, Inc -------------------- Zimbra :: the leader in open source messaging and collaboration
Download (untitled) / with headers
text/plain 1.8k
On Mon Jun 18 17:29:18 2007, quanah@zimbra.com wrote: Show quoted text
> > > --On June 15, 2007 3:54:40 PM -0400 Paul Marquess via RT > <bug-Compress-Zlib@rt.cpan.org> wrote: >
> > > > <URL: http://rt.cpan.org/Ticket/Display.html?id=27598 > > > > > On Fri Jun 15 15:03:57 2007, quanah@zimbra.com wrote:
> >> Please see: > >> > >> <http://www.perlmonks.org/?node_id=594914> > >> > >> This bug affects RHEL4 - Red Hat Enterprise Linux ES release 4
> > (Nahant
> >> Update 4) > >> > >> This is perl, v5.8.5 built for i386-linux-thread-multi > >> > >> We use CPAN to grab the latest modules and build them, which grabs
> > 2.004
> >> which makes downgrading to 1.42 difficult (though possibly
> > manually). This
> >> bug has been around for half a year now, it would be great to see
the Show quoted text
> > fix. > > > > Hi Quanah > > > > thanks for reminding me about this. I reviewed the mail thread and
it Show quoted text
> > sort of petered out without coming to a conclusion. > > > > To summarise the issue - the problem is my reliance on dualvar from > > Scalar::Util? If I included my own version of dualvar does the
problem Show quoted text
> > go away?
> > Hi Paul, > > I asked Gaal about this and he said: > > Hi Quanah, > > On 6/18/07, Quanah Gibson-Mount <quanah@zimbra.com> wrote:
with the Show quoted text
> > Compress-Zlib author, and the author is curious to know the best
way to Show quoted text
> > proceed with fixing it. I thought you might have some ideas.
> > As far as I recall, the problem is that one stage of the PAR build > process has no > access to XS. So no, implementing dualvar instead of relying on the
one in Show quoted text
> Scalar::Util, because (presumably) the alternative version won't be
loadable Show quoted text
> either. Unless there's a clever way to write it in pure Perl, but I > can't think of > one.
So if dualvar isn't the issue, then what is? Paul
CC: Gaal Yahas <gaal [...] forum2.org>
Subject: Re: [rt.cpan.org #27598] XS version error from Compress:Zlib
Date: Tue, 19 Jun 2007 10:13:32 -0700
To: bug-Compress-Zlib [...] rt.cpan.org
From: Quanah Gibson-Mount <quanah [...] zimbra.com>
Download (untitled) / with headers
text/plain 615b
--On June 18, 2007 5:45:04 PM -0400 Paul Marquess via RT <bug-Compress-Zlib@rt.cpan.org> wrote: Show quoted text
> So if dualvar isn't the issue, then what is?
Hi Paul, Unfortunately, I don't have the answer. I just ran into the problem and found Gaal's write-up on it, and noticed that no forward movement seemed to be occurring. I'm CC'ing Gaal because he seems to have the best idea of the issues here. Hopefully this can be resolved this time around. :) --Quanah -- Quanah Gibson-Mount Principal Software Engineer Zimbra, Inc -------------------- Zimbra :: the leader in open source messaging and collaboration
CC: bug-Compress-Zlib [...] rt.cpan.org
Subject: Re: [rt.cpan.org #27598] XS version error from Compress:Zlib
Date: Tue, 19 Jun 2007 20:22:28 +0300
To: "Quanah Gibson-Mount" <quanah [...] zimbra.com>
From: "Gaal Yahas" <gaal [...] forum2.org>
Download (untitled) / with headers
text/plain 1.3k
I'd suggest working with Steffen Müller, PAR maintainer, to try to understand why this problem manifests in Red Hat (and CentOS) and not, say, Debian. Or perhaps interest someone from Red Hat? As noted elsewhere, there's a particular stage in myldr building PAR that apparently cannot load dynamic code, which is why dualvar fails. Does all dynamic loading fail at that stage? I don't know; if it does why doesn't the earlier version of Compress::Zlib not exhibit the problem? Unfortunately I don't have a setup to test any of this any more, but this should hopefully get you going. On 6/19/07, Quanah Gibson-Mount <quanah@zimbra.com> wrote: Show quoted text
> > > --On June 18, 2007 5:45:04 PM -0400 Paul Marquess via RT > <bug-Compress-Zlib@rt.cpan.org> wrote: >
> > So if dualvar isn't the issue, then what is?
> > > Hi Paul, > > Unfortunately, I don't have the answer. I just ran into the problem and > found Gaal's write-up on it, and noticed that no forward movement seemed to > be occurring. I'm CC'ing Gaal because he seems to have the best idea of > the issues here. Hopefully this can be resolved this time around. :) > > --Quanah > > -- > Quanah Gibson-Mount > Principal Software Engineer > Zimbra, Inc > -------------------- > Zimbra :: the leader in open source messaging and collaboration >
-- Gaal Yahas <gaal@forum2.org> http://gaal.livejournal.com/
Subject: Re: [rt.cpan.org #27598] XS version error from Compress:Zlib
Date: Wed, 7 Nov 2007 04:03:14 -0700
To: <bug-compress-zlib [...] rt.cpan.org>
From: plu tard <plutard12 [...] hotmail.com>
Download (untitled) / with headers
text/plain 585b
I was just bitten by this too. Machine is running CentOS 3.9, and Yum did an automatic upgrade of the Perl RPM to perl 2:5.8.0-97.EL3.i386. After the upgrade I was getting the "You don't have XS version" error. The trick was to forcefully reinstall Scalar::Util. That seems to build the XS extension, dualvar is available again, and all is good. It appears that RedHat/CentOS is not including the XS code in the RPMs. HTH. Show quoted text
_________________________________________________________________ Peek-a-boo FREE Tricks & Treats for You! http://www.reallivemoms.com?ocid=TXT_TAGHM&loc=us
Download (untitled) / with headers
text/plain 540b
On Wed Nov 07 06:03:52 2007, plutard12@hotmail.com wrote: Show quoted text
> I was just bitten by this too. > > Machine is running CentOS 3.9, and Yum did an automatic > upgrade of the Perl RPM to perl 2:5.8.0-97.EL3.i386. > > After the upgrade I was getting the "You don't have XS version" > error. > > The trick was to forcefully reinstall Scalar::Util. That seems to build > the XS extension, dualvar is available again, and all is good. > > It appears that RedHat/CentOS is not including the XS code in the > RPMs.
Thanks for the feedback. Paul
Subject: Re: [rt.cpan.org #27598] Resolved: XS version error from Compress:Zlib
Date: Tue, 21 Oct 2008 11:06:00 -0700
To: bug-Compress-Zlib [...] rt.cpan.org
From: Quanah Gibson-Mount <quanah [...] zimbra.com>
Download (untitled) / with headers
text/plain 505b
--On Monday, May 05, 2008 4:06 PM -0400 Paul Marquess via RT <bug-Compress-Zlib@rt.cpan.org> wrote: Show quoted text
> <URL: http://rt.cpan.org/Ticket/Display.html?id=27598 > > > According to our records, your request has been resolved. If you have any > further questions or concerns, please respond to this message.
Paul, How was this bug resolved? Thanks, Quanah -- Quanah Gibson-Mount Principal Software Engineer Zimbra, Inc -------------------- Zimbra :: the leader in open source messaging and collaboration
Download (untitled) / with headers
text/plain 718b
On Tue Oct 21 14:06:19 2008, quanah@zimbra.com wrote: Show quoted text
> --On Monday, May 05, 2008 4:06 PM -0400 Paul Marquess via RT > <bug-Compress-Zlib@rt.cpan.org> wrote: >
> > <URL: http://rt.cpan.org/Ticket/Display.html?id=27598 > > > > > According to our records, your request has been resolved. If you
have any Show quoted text
> > further questions or concerns, please respond to this message.
> > Paul, > > How was this bug resolved?
Hi Quanah, the last response before yours included this (from this time last year) Show quoted text
> The trick was to forcefully reinstall Scalar::Util. That seems to build > the XS extension, dualvar is available again, and all is good.
If that doesn't sort the problem, I'm happy to keep this open. cheers Paul
Subject: Re: [rt.cpan.org #27598] XS version error from Compress:Zlib
Date: Fri, 24 Oct 2008 13:09:44 -0700
To: bug-Compress-Zlib [...] rt.cpan.org
From: Quanah Gibson-Mount <quanah [...] zimbra.com>
Download (untitled) / with headers
text/plain 1.1k
--On October 24, 2008 5:26:12 AM -0400 Paul Marquess via RT <bug-Compress-Zlib@rt.cpan.org> wrote: Show quoted text
> <URL: http://rt.cpan.org/Ticket/Display.html?id=27598 > > > On Tue Oct 21 14:06:19 2008, quanah@zimbra.com wrote:
>> --On Monday, May 05, 2008 4:06 PM -0400 Paul Marquess via RT >> <bug-Compress-Zlib@rt.cpan.org> wrote: >>
>> > <URL: http://rt.cpan.org/Ticket/Display.html?id=27598 > >> > >> > According to our records, your request has been resolved. If you
> have any
>> > further questions or concerns, please respond to this message.
>> >> Paul, >> >> How was this bug resolved?
> > Hi Quanah, > > the last response before yours included this (from this time last year) >
>> The trick was to forcefully reinstall Scalar::Util. That seems to build >> the XS extension, dualvar is available again, and all is good.
> > If that doesn't sort the problem, I'm happy to keep this open.
Reinstalling XS is not a valid solution to a problem with the module. So I guess this isn't actually fixed. --Quanah -- Quanah Gibson-Mount Principal Software Engineer Zimbra, Inc -------------------- Zimbra :: the leader in open source messaging and collaboration
Download (untitled) / with headers
text/plain 1.2k
On Fri Oct 24 16:10:22 2008, quanah@zimbra.com wrote: Show quoted text
> > > --On October 24, 2008 5:26:12 AM -0400 Paul Marquess via RT > <bug-Compress-Zlib@rt.cpan.org> wrote: >
> > <URL: http://rt.cpan.org/Ticket/Display.html?id=27598 > > > > > On Tue Oct 21 14:06:19 2008, quanah@zimbra.com wrote:
> >> --On Monday, May 05, 2008 4:06 PM -0400 Paul Marquess via RT > >> <bug-Compress-Zlib@rt.cpan.org> wrote: > >>
> >> > <URL: http://rt.cpan.org/Ticket/Display.html?id=27598 > > >> > > >> > According to our records, your request has been resolved. If you
> > have any
> >> > further questions or concerns, please respond to this message.
> >> > >> Paul, > >> > >> How was this bug resolved?
> > > > Hi Quanah, > > > > the last response before yours included this (from this time last year) > >
> >> The trick was to forcefully reinstall Scalar::Util. That seems to build > >> the XS extension, dualvar is available again, and all is good.
> > > > If that doesn't sort the problem, I'm happy to keep this open.
> > Reinstalling XS is not a valid solution to a problem with the module.
So I Show quoted text
> guess this isn't actually fixed. >
Why is that? Can you give me more details please? Quanah ps I'm probably going to remove the dependency on Scalar::Util in the next version of Compress::Zlib.
Subject: Re: [rt.cpan.org #27598] XS version error from Compress:Zlib
Date: Mon, 03 Nov 2008 12:00:03 -0800
To: bug-Compress-Zlib [...] rt.cpan.org
From: Quanah Gibson-Mount <quanah [...] zimbra.com>
Download (untitled) / with headers
text/plain 837b
--On Saturday, November 01, 2008 1:18 PM -0400 Paul Marquess via RT <bug-Compress-Zlib@rt.cpan.org> wrote: Show quoted text
>> Reinstalling XS is not a valid solution to a problem with the module.
> So I
>> guess this isn't actually fixed. >>
> > Why is that? Can you give me more details please? > > Quanah > > ps I'm probably going to remove the dependency on Scalar::Util in the > next version of Compress::Zlib.
Because XS is a core part of what's shipped by various distro's, and things get really murky and unhappy when you do that. We prefer our product to not mess with core perl modules if at all possible. Do you have a timeline on the next release of Compress::Zlib? Regards, Quanah -- Quanah Gibson-Mount Principal Software Engineer Zimbra, Inc -------------------- Zimbra :: the leader in open source messaging and collaboration
Download (untitled) / with headers
text/plain 1.5k
On Mon Nov 03 15:00:23 2008, quanah@zimbra.com wrote: Show quoted text
> --On Saturday, November 01, 2008 1:18 PM -0400 Paul Marquess via RT > <bug-Compress-Zlib@rt.cpan.org> wrote: >
> >> Reinstalling XS is not a valid solution to a problem with the module.
> > So I
> >> guess this isn't actually fixed. > >>
> > > > Why is that? Can you give me more details please? > > > > Quanah > > > > ps I'm probably going to remove the dependency on Scalar::Util in the > > next version of Compress::Zlib.
> > Because XS is a core part of what's shipped by various distro's, and
things Show quoted text
> get really murky and unhappy when you do that. We prefer our product to > not mess with core perl modules if at all possible.
Both Scalar::Util and Compress::Zlib are core modules. Just so you are clear about what I intend to do, I'm just going to copy the sub-set of the Scalar::Util XS code and include it with IO::Compress::Base - which is used in turn by Compress::Zlib. So although there will still be an XS aspect to this, it won't be dependent on how Scalar::Util has been built on your system. It does mean that if you have a system with an older version of Compress::Zlib, you will have to mess with a core module (Compress::Zlib is now a core module) and install the new version if you want this functionality. Not really that much different from installing the XS version of Scalar::Util. :-) Show quoted text
> Do you have a timeline on the next release of Compress::Zlib?
Not really - it is just dependent on when I can find enough spare time to do it. It is part of a larger change that I'm in the middle of implementing. Paul
Subject: Re: [rt.cpan.org #27598] XS version error from Compress:Zlib
Date: Tue, 07 Apr 2009 13:19:55 -0700
To: bug-Compress-Zlib [...] rt.cpan.org
From: Quanah Gibson-Mount <quanah [...] zimbra.com>
Download (untitled) / with headers
text/plain 484b
--On Monday, November 03, 2008 4:32 PM -0500 Paul Marquess via RT <bug-Compress-Zlib@rt.cpan.org> wrote: Show quoted text
> Not really - it is just dependent on when I can find enough spare time > to do it. It is part of a larger change that I'm in the middle of > implementing.
Is this done in the new IO-Compress-2.017 rewrite? Thanks, Quanah -- Quanah Gibson-Mount Principal Software Engineer Zimbra, Inc -------------------- Zimbra :: the leader in open source messaging and collaboration
Download (untitled) / with headers
text/plain 407b
On Tue Apr 07 16:20:18 2009, quanah@zimbra.com wrote: Show quoted text
> --On Monday, November 03, 2008 4:32 PM -0500 Paul Marquess via RT > <bug-Compress-Zlib@rt.cpan.org> wrote: >
> > Not really - it is just dependent on when I can find enough spare time > > to do it. It is part of a larger change that I'm in the middle of > > implementing.
> > Is this done in the new IO-Compress-2.017 rewrite?
No, it isn't Paul
note RT #25364 is a duplicate of this issue.
Subject: Re: [rt.cpan.org #27598] XS version error from Compress:Zlib
Date: Tue, 13 Oct 2009 13:04:24 -0700
To: bug-Compress-Zlib [...] rt.cpan.org
From: Quanah Gibson-Mount <quanah [...] zimbra.com>
Download (untitled) / with headers
text/plain 435b
--On Wednesday, April 08, 2009 5:09 AM -0400 Paul Marquess via RT <bug-Compress-Zlib@rt.cpan.org> wrote: Show quoted text
> <URL: https://rt.cpan.org/Ticket/Display.html?id=27598 > > > note RT #25364 is a duplicate of this issue.
It seems like the queue should be changed to IO-Compress. --Quanah -- Quanah Gibson-Mount Principal Software Engineer Zimbra, Inc -------------------- Zimbra :: the leader in open source messaging and collaboration


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.