Skip Menu |
 

This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id: 27579
Status: resolved
Priority: 0/
Queue: Module-Install

People
Owner: Nobody in particular
Requestors: jeremiah [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Wishlist
Broken in: 0.66_02
Fixed in: 0.73



Subject: Module::Install won't run on 5.8.6
Download (untitled) / with headers
text/plain 627b
I used Module::Install to create a Makefile.PL file so that I can ensure that all needed modules are installed when I make a 'distribution' of my CGI script. When I run `perl Makefile.PL` I get the follow error message and the resulting Makefile is not written. include inc/Module/Install/WriteAll.pm Writing META.yml include inc/Module/Install/Win32.pm include inc/Module/Install/Can.pm include inc/Module/Install/Fetch.pm ERROR: perl: Version 5.008006 is installed, but we need version >= 5.008008 at /Library/Perl/5.8.6/Module/Install/Makefile.pm line 158. Local machine information: OS: Mac OS X 10.4.9 perl: 5.8.6
Download (untitled) / with headers
text/plain 257b
if ( my $perl_version = $self->perl_version ) { eval "use $perl_version; 1" or die "ERROR: perl: Version $] is installed, " . "but we need version >= $perl_version"; } This is the error message if YOUR PACKAGE has that dependecy, not M:I itself.
Subject: Re: [rt.cpan.org #27579] Module::Install won't run on 5.8.6
Date: Wed, 31 Oct 2007 17:26:24 +0100
To: via RT <bug-Module-Install [...] rt.cpan.org>
From: "Jeremiah C. Foster" <jeremiah [...] jeremiahfoster.com>
Download (untitled) / with headers
text/plain 504b
Wed, Oct 31, 2007 at 07:07:05AM -0400: via RT mangled some bits into this alignment: Show quoted text
> > <URL: http://rt.cpan.org/Ticket/Display.html?id=27579 > > > if ( my $perl_version = $self->perl_version ) { > eval "use $perl_version; 1" > or die "ERROR: perl: Version $] is installed, " > . "but we need version >= $perl_version"; > } > > This is the error message if YOUR PACKAGE has that dependecy, not M:I > itself.
Okay. Weird because my package does not have that dependency. Jeremiah
Download (untitled) / with headers
text/plain 321b
Swatting bugs here. M::I certainly does run on 5.8.6 with my testing; I've got modules that use it to install on everything back to 5.005_ancient, so I'm marking this as not-a-bug and closing it. If the problem still exists, then submitting a failing test case would be appreciating in tracking down what's going wrong.
Pending more information, closing this


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.