Skip Menu |
 

This queue is for tickets about the CGI-Application CPAN distribution.

Report information
The Basics
Id: 2757
Status: resolved
Priority: 0/
Queue: CGI-Application

People
Owner: MARKSTOS [...] cpan.org
Requestors: mattr [...] telebody.com
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 3.1
Fixed in: (no value)



Subject: Pod code doesn't work for cgiapp_postrun in 5.8 linux
Download (untitled) / with headers
text/plain 794b
Thank you for working on this great module. I found the sample code for cgiapp_postrun does not work in perl 5.8 (redhat linux 9, autobuilt by cpan). Below is the code sampel from the pod and a fix. Best wishes from Matt Rosin (mattr at telebody.com), Tokyo, Japan sub cgiapp_postrun { # output filters and wrapping templates here my $self = shift; # app instance my $output_ref = shift; # Enclose output HTML table my $new_output = "<table border=1>"; $new_output .= "<tr><td> Hello, World! </td></tr>"; $new_output .= "<tr><td>". $$output_ref ."</td></tr>"; $new_output .= "</table>"; # Replace old output with new output # $output_ref = \$new_output; ## DOESN'T WORK IN 5.8 (FROM POD) $$output_ref = $new_output; ## WORKS IN 5.8 }
From: markstos [...] cpan.org
Download (untitled) / with headers
text/plain 491b
[guest - Sun Jun 8 05:07:47 2003]: Show quoted text
> Thank you for working on this great module. I found the sample code > for cgiapp_postrun does not work in perl 5.8 (redhat linux 9, > autobuilt by cpan). Below is the code sampel from the pod and a > fix. Best wishes from Matt Rosin (mattr at telebody.com), Tokyo, > Japan
Thanks for the report. This was indeed a bug in the documentation. It's been fixed in a development version for release in 3.2. (Hopefully Real Soon Now!) Mark


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.