Skip Menu |
 

This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id: 2756
Status: resolved
Priority: 0/
Queue: Module-Install

People
Owner: Nobody in particular
Requestors:
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 0.20
Fixed in: (no value)



Subject: make ppd doesn't list prerequisites properly
Download (untitled) / with headers
text/plain 549b
`make ppd' just doesn't work I'd consider this critical, but only cause I make lots of ppm packages ;) Try building PAR and doing make ppd to see that none of requires ('File::Temp'); requires ('Compress::Zlib' => 1.14); requires ('Archive::Zip' => 1.0); requires ('Module::ScanDeps' => 0.19); translate into <DEPENDENCY NAME="File-Temp" VERSION="0,0,0,0" /> ... in the resulting ppd file (PAR.ppd). I looked at ToDo, and this is not listed. You should also probably test this feature when you add it. -- Peace
Verified as been resolved by PAR 0.72. Thanks, /Autrijus/


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.