Skip Menu |
 

This queue is for tickets about the CPANPLUS-Dist-Deb CPAN distribution.

Report information
The Basics
Id: 27315
Status: resolved
Priority: 0/
Queue: CPANPLUS-Dist-Deb

People
Owner: Nobody in particular
Requestors: TEEJAY [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Wishlist
Broken in: 0.05
Fixed in: (no value)



Subject: min version for dependancy ignoring those provided in Makefile.PL
Download (untitled) / with headers
text/plain 380b
Yet more bother - sorry :) The min version for dependancies in a created debian package is based on the latest version in CPAN rather than those provided in Makefile.PL It's mildly annoying and not that big a deal - especially as I run a script after cpan2dist to add local dependancies from the makefile, it now also "fixes" to a lower version if the Makefile.PL provides one.
Download (untitled) / with headers
text/plain 570b
On Mon May 28 08:19:15 2007, TEEJAY wrote: Show quoted text
> Yet more bother - sorry :) > > The min version for dependancies in a created debian package is based on > the latest version in CPAN rather than those provided in Makefile.PL
Nope. The prerequisite listed in the .deb is based on the version we *built* the .deb with (as that way we know it works). So if you're installed version is sufficient, it'll use that version. If you dont have a prereq installed, we're grabbing it from CPAN and then *that* version is used. For details, see CPANPLUS::Dist::Deb:475 and onwards.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.