Skip Menu |
 

This queue is for tickets about the Wx CPAN distribution.

Report information
The Basics
Id: 26934
Status: new
Priority: 0/
Queue: Wx

People
Owner: Nobody in particular
Requestors: vince [...] greffsite.com
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 0.74
Fixed in: (no value)



Subject: install failed because wx.so cannot find libwx_gtk2_adv-2.8.so.0
Download (untitled) / with headers
text/plain 813b
I tried installing on FC4 with cpan install Wx but the install failed because ldd /data/ADMIN/INSTALL/cpan/build/Wx-0.74/blib/arch/auto/Wx/Wx.so linux-gate.so.1 => (0x005b6000) libpthread.so.0 => /lib/libpthread.so.0 (0x00f50000) libwx_gtk2_adv-2.8.so.0 => not found libwx_gtk2_core-2.8.so.0 => not found libwx_base-2.8.so.0 => not found libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00d42000) libm.so.6 => /lib/libm.so.6 (0x00a3c000) libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x0085c000) libc.so.6 => /lib/libc.so.6 (0x00670000) /lib/ld-linux.so.2 (0x005b7000) if I manually add LD_LIBRARY_PATH=/data/ADMIN/INSTALL/cpan/build/Alien-wxWidgets-0.31/wxWidgets-2.8.3/bld/lib export LD_LIBRARY_PATH it will build and test properly.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.