Skip Menu |
 

This queue is for tickets about the CGI-Application-Plugin-DevPopup CPAN distribution.

Report information
The Basics
Id: 26673
Status: resolved
Priority: 0/
Queue: CGI-Application-Plugin-DevPopup

People
Owner: Nobody in particular
Requestors: dan.horne [...] redbone.co.nz
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 0.951
Fixed in: (no value)



Subject: Install test fail
Download (untitled) / with headers
text/plain 4.2k
Hi I tried installing the latest version but get the following test error t/02-production....NOK 1 # Failed test 'Report not turned on' # in t/02-production.t at line 39. # 'Content-Type: text/html; charset=ISO-8859-1 # # <html><body>Hi there! # <script language="javascript"> # var devpopup_window = window.open("", "devpopup_window", "height=400,width=600,scrollbars,resizable"); # devpopup_window.document.write("<?xml version=\"1.0\"?>\n" + # "<!DOCTYPE html PUBLIC \"-//W3C//DTD XHTML 1.0 Transitional//EN\"\n" + # " \"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd\">\n" + # "\n" + # "<html xmlns=\"http://www.w3.org/1999/xhtml\">\n" + # "<head>\n" + # " <title>Devpopup results</title>\n" + # " <style type=\"text/css\">\n" + # " div.report { border: dotted 1px black; margin: 1em;}\n" + # " div.report h2 { color: #000; background-color: #ddd; padding:.2em; margin-top:0;}\n" + # " div.report_full, div.report_summary { padding: 0em 1em; }\n" + # " a:hover, div.report h2:hover, a.print_button:hover { cursor: pointer; background-color: #eee; }\n" + # " a { text-decoration: underline }\n" + # " a.print_button { text-align: right; float: right; clear: right; padding: .2em; margin-right: 1em; color: #000; background-color:#ddd; border:solid 1px #444; }\n" + # " // severity colors\n" + # " .sev_debug { background-color: #ccffcc; color: #000; }\n" + # " .sev_info { } // default\n" + # " .sev_warning { background-color: #ffff99; color: #000; }\n" + # " .sev_error { background-color: #ff9999; color: #000; }\n" + # " .sev_fatal { background-color: #ff6600; color: #fff; font-weight: bold; }\n" + # " </style>\n" + # ""); # devpopup_window.document.write(" <s"); # devpopup_window.document.write("cript type=\"text/javascript\">"); # devpopup_window.document.write(" function swap(id1,id2)\n" + # " {\n" + # " var d1 = document.getElementById(id1);\n" + # " var d2 = document.getElementById(id2);\n" + # " var s = d1.style.display;\n" + # " d1.style.display = d2.style.display;\n" + # " d2.style.display = s;\n" + # " }\n" + # ""); # devpopup_window.document.write(" <"); # devpopup_window.document.write("/script>"); # devpopup_window.document.write("</head>\n" + # "<body>\n" + # "<h1>Devpopup report for My::App -&gt; runmode</h1>\n" + # "<a href=\"javascript:window.print()\" class=\"print_button\">Print</a>\n" + # "<div id=\"titles\">\n" + # "<ul>\n" + # "\n" + # " <li class=\"_sev_info\">\n" + # " <a onclick=\"swap('#DPS1','#DPR1')\">Test 1</a> - \n" + # " </li>\n" + # "\n" + # "</ul>\n" + # "</div>\n" + # "\n" + # "\n" + # "<div id=\"#DP1\" class=\"report\">\n" + # " <h2 id=\"#DPH1\"\n" + # " class=\"_sev_info\"\n" + # " onclick=\"swap('#DPS1','#DPR1')\">\n" + # " Test 1\n" + # " </h2>\n" + # " <div id=\"#DPS1\" class=\"report_summary\">\n" + # " \n" + # " </div>\n" + # " <div id=\"#DPR1\" class=\"report_full\" style=\"display:none\">Test 1 report body</div>\n" + # "</div>\n" + # "\n" + # "\n" + # "</body>\n" + # "</html>\n" + # ""); # devpopup_window.document.close(); # devpopup_window.focus(); # </script> # # </body></html>' # matches '(?-xism:Test 1 report body)' # Looks like you failed 1 test of 1. t/02-production....dubious Test returned status 1 (wstat 256, 0x100) DIED. FAILED test 1 Failed 1/1 tests, 0.00% okay t/pod-coverage.....ok t/pod..............ok Failed Test Stat Wstat Total Fail Failed List of Failed ------------------------------------------------------------------------------- t/02-production.t 1 256 1 1 100.00% 1 Failed 1/5 test scripts, 80.00% okay. 1/11 subtests failed, 90.91% okay. make: *** [test_dynamic] Error 255
Subject: Re: [rt.cpan.org #26673] Install test fail
Date: Wed, 25 Apr 2007 22:59:09 +0200
To: bug-CGI-Application-Plugin-DevPopup [...] rt.cpan.org
From: Rhesa Rozendaal <rhesa [...] cpan.org>
Download (untitled) / with headers
text/plain 822b
Hi Dan, Weird, it passes for me, as well as the CPAN testers (see http://cpantesters.perl.org/show/CGI-Application-Plugin-DevPopup.html). The _only_ way this could happen is when your environment already has CAP_DEVPOPUP_EXEC defined prior to starting the test. I assume you didn't do that on purpose just to tease me ;-), so I'll add a safeguard to the test for that. If you feel like it, add this line to t/02-production.t (somewhere near the top): delete $ENV{'CAP_DEVPOPUP_EXEC'}; That should let it pass all the tests, and let you install it. Let me know how it goes. Rhesa dan.horne@redbone.co.nz via RT wrote: Show quoted text
> Hi > > I tried installing the latest version but get the following test error > > t/02-production....NOK 1 > # Failed test 'Report not turned on' > # in t/02-production.t at line 39.
From: dan.horne [...] redbone.co.nz
Download (untitled) / with headers
text/plain 247b
Hi Rhesa Show quoted text
> The _only_ way this could happen is when your environment already has > CAP_DEVPOPUP_EXEC defined prior to starting the test.
Whoops, that was it. I unset the environment variable, and all the tests passed. Thanks for your help Dan
Download (untitled) / with headers
text/plain 124b
Next version will not assume that the env variable is cleared, and do that explicitly. Thanks for reporting, Dan :-) Rhesa


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.