Skip Menu |
 
rt.cpan.org will be shut down on March 1st, 2021.

This queue is for tickets about the Alzabo CPAN distribution.

Maintainer(s)' notes

Not really maintained any more. Interested in taking it over? Email the author.

Report information
The Basics
Id: 2642
Status: resolved
Priority: 0/
Queue: Alzabo

People
Owner: DROLSKY [...] cpan.org
Requestors: william [...] knowmad.com
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.72
Fixed in: 0.80



Subject: Prerequisites are not properly defined
Download (untitled) / with headers
text/plain 993b
I went to setup Alzabo today to try all the great features I've been hearing about. The installation via CPAN was a bumpy ride due to undefined prerequisites. I often had to exit the installation process and install a prerequisite. Most Perl packages can automatically figure out what prerequisites are required. Alzabo spit out a message about wanting a few modules but that wasn't enough to prevent CPAN from attempting to begin the make process which failed miserably due to the following missing packages-->Graphviz, Params::Validate, Class::Factory::Util, and HTTP::BrowserDetect. Furthermore, and the reason which I classified this report as severe, Alzabo fails to install if an older version of Module::Build is installed (specifically 0.15). Ins this case, the Alzabo install script didn't even mention that I should get an updated version of this module. Hope you're able to fix these dependencies to make the install process smoother for other potential users. Regards, William
Date: Fri, 23 May 2003 23:52:30 -0500 (CDT)
From: Dave Rolsky <autarch [...] urth.org>
To: Guest via RT <bug-Alzabo [...] rt.cpan.org>
Subject: Re: [cpan #2642] Prerequisites are not properly defined
RT-Send-Cc:
Download (untitled) / with headers
text/plain 1.1k
On Fri, 23 May 2003, Guest via RT wrote: Show quoted text
> I went to setup Alzabo today to try all the great features I've been > hearing about. The installation via CPAN was a bumpy ride due to > undefined prerequisites. I often had to exit the installation process > and install a prerequisite. > > Most Perl packages can automatically figure out what prerequisites are > required. Alzabo spit out a message about wanting a few modules but that > wasn't enough to prevent CPAN from attempting to begin the make process > which failed miserably due to the following missing packages-->Graphviz, > Params::Validate, Class::Factory::Util, and HTTP::BrowserDetect. > > Furthermore, and the reason which I classified this report as severe, > Alzabo fails to install if an older version of Module::Build is > installed (specifically 0.15). Ins this case, the Alzabo install script > didn't even mention that I should get an updated version of this module.
More details please. Did it try to install _any_ prereqs? How did you answer the various install questions? -dave /*======================= House Absolute Consulting www.houseabsolute.com =======================*/


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.