Skip Menu |
 

This queue is for tickets about the Class-Data-Accessor CPAN distribution.

Report information
The Basics
Id: 26271
Status: resolved
Worked: 1 min
Priority: 0/
Queue: Class-Data-Accessor

People
Owner: claco [...] cpan.org
Requestors: m.nooning [...] comcast.net
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 0.03
Fixed in: (no value)



Subject: No 'file' or 'fh' parameter given in an invocation to a required module.
Class-Data-Accessor-0.03, Windows XP, SP2, 512Meg Ram, ActiveState Perl 5.8.8, Binary build 820. Hello, I am in the middle of a dependency hell with the end goal of installing all of the Catalyst files on Windows. Class::Data::Accessor uses PodParser, which uses Pod::Parser. At first you might think the problem is with PodParser or Pod::Parser because the error message ultimately comes from Pod::Parser. However, I just installed the latest versions of both of them, and they passed all of their tests. Anyway, here is the "nmake" for Class::Data::Accessor and the error report. Show quoted text
>nmake
Microsoft (R) Program Maintenance Utility Version 7.00.9466 Copyright (C) Microsoft Corporation. All rights reserved. C:\Perl\bin\perl.exe Build --makefile_env_macros 1 lib\Class\Data\Accessor.pm -> blib\lib\Class\Data\Accessor.pm Manifying blib\lib/Class/Data/Accessor.pm -> blib\libdoc\Class.Data.Accessor.3 No 'file' or 'fh' parameter given at C:/Perl/site/lib/Module/Build/PodParser.pm line 24. NMAKE : fatal error U1077: 'C:\Perl\bin\perl.exe' : return code '0x2' Stop.
Subject: Re: [rt.cpan.org #26271] No 'file' or 'fh' parameter given in an invocation to a required module.
Date: Wed, 11 Apr 2007 12:56:28 -0400
To: bug-Class-Data-Accessor [...] rt.cpan.org
From: "Christopher H. Laco" <claco [...] chrislaco.com>
Download (untitled) / with headers
text/plain 2.1k
Malcolm Nooning via RT wrote: Show quoted text
> Wed Apr 11 12:46:28 2007: Request 26271 was acted upon. > Transaction: Ticket created by m.nooning@comcast.net > Queue: Class-Data-Accessor > Subject: No 'file' or 'fh' parameter given in an invocation to a required > module. > Broken in: 0.03 > Severity: Important > Owner: Nobody > Requestors: m.nooning@comcast.net > Status: new > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=26271 > > > > Class-Data-Accessor-0.03, Windows XP, SP2, 512Meg Ram, ActiveState Perl > 5.8.8, Binary build 820. > > Hello, > > I am in the middle of a dependency hell with the end goal of installing > all of the Catalyst files on Windows. Class::Data::Accessor uses > PodParser, which uses Pod::Parser. > > At first you might think the problem is with PodParser or Pod::Parser > because the error message ultimately comes from Pod::Parser. However, I > just installed the latest versions of both of them, and they passed all > of their tests. Anyway, here is the "nmake" for Class::Data::Accessor > and the error report. >
>> nmake
> Microsoft (R) Program Maintenance Utility Version 7.00.9466 > Copyright (C) Microsoft Corporation. All rights reserved. > > C:\Perl\bin\perl.exe Build --makefile_env_macros 1 > lib\Class\Data\Accessor.pm -> blib\lib\Class\Data\Accessor.pm > Manifying blib\lib/Class/Data/Accessor.pm -> > blib\libdoc\Class.Data.Accessor.3 > No 'file' or 'fh' parameter given at > C:/Perl/site/lib/Module/Build/PodParser.pm line 24. > NMAKE : fatal error U1077: 'C:\Perl\bin\perl.exe' : return code '0x2' > Stop. > > >
No, I would be inclined to blame Module::Build::PodParser. :-) Class::Data::Accessor doesn't use PodParser, Module::Build (Build.PL) does. If you Google Group for "No 'file' or 'fh' parameter given", you will see many modules failing with this error, many of which use Module::Build, but not PodParser itself. I would make sure you have the latest and greatest Module::Build installed. With that said, if you're trying to get Catalyst going on Windows, you will have much much better luck with Strawberry Perl as it includes it's own compiling mechanisms and more often "Just Works" compared to AS perl. -=Chris
Download signature.asc
application/pgp-signature 189b

Message body not shown because it is not plain text.

From: m.nooning [...] comcast.net
Download (untitled) / with headers
text/plain 269b
Hmph! You are right. The problem was with Module Build. I downloaded and installed Module-Build-0.2807, and the problems went away. Thanks for the tip. I do not know how to mark a ticket as "resolved" so that it goes away. If you know how, please do so. Thanks
Resolved after Module::Build upgrade.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.