Skip Menu |
 

This queue is for tickets about the libwww-perl CPAN distribution.

Report information
The Basics
Id: 26152
Status: resolved
Priority: 0/
Queue: libwww-perl

People
Owner: Nobody in particular
Requestors: at [...] altlinux.ru
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: [PATCH] Protocol/https10.pm, Net/HTTPS.pm: when both IO::Socket::SSL and Net::SSL are loaded, use the latter
Date: Sun, 8 Apr 2007 00:31:26 +0400
To: bug-libwww-perl [...] rt.cpan.org
From: Alexey Tourbin <at [...] altlinux.ru>
Download (untitled) / with headers
text/plain 1.1k
--- lib/LWP/Protocol/https10.pm | 5 ++++- lib/Net/HTTPS.pm | 5 ++++- 2 files changed, 8 insertions(+), 2 deletions(-) diff --git a/lib/LWP/Protocol/https10.pm b/lib/LWP/Protocol/https10.pm index 4a92be6..f367904 100644 --- a/lib/LWP/Protocol/https10.pm +++ b/lib/LWP/Protocol/https10.pm @@ -7,7 +7,10 @@ package LWP::Protocol::https10; # Figure out which SSL implementation to use use vars qw($SSL_CLASS); -if ($IO::Socket::SSL::VERSION) { +if ($Net::SSL::VERSION) { + $SSL_SOCKET_CLASS = "Net::SSL"; +} +elsif ($IO::Socket::SSL::VERSION) { $SSL_CLASS = "IO::Socket::SSL"; # it was already loaded } else { diff --git a/lib/Net/HTTPS.pm b/lib/Net/HTTPS.pm index b722ac1..cef29ca 100644 --- a/lib/Net/HTTPS.pm +++ b/lib/Net/HTTPS.pm @@ -8,7 +8,10 @@ use vars qw($VERSION $SSL_SOCKET_CLASS @ISA); $VERSION = "1.00"; # Figure out which SSL implementation to use -if ($IO::Socket::SSL::VERSION) { +if ($Net::SSL::VERSION) { + $SSL_SOCKET_CLASS = "Net::SSL"; +} +elsif ($IO::Socket::SSL::VERSION) { $SSL_SOCKET_CLASS = "IO::Socket::SSL"; # it was already loaded } else { -- 1.5.1.GIT
Download (untitled) / with headers
text/plain 531b
On Sat Apr 07 16:32:38 2007, at@altlinux.ru wrote: Show quoted text
> --- a/lib/LWP/Protocol/https10.pm > +++ b/lib/LWP/Protocol/https10.pm > @@ -7,7 +7,10 @@ package LWP::Protocol::https10; > > # Figure out which SSL implementation to use > use vars qw($SSL_CLASS); > -if ($IO::Socket::SSL::VERSION) { > +if ($Net::SSL::VERSION) { > + $SSL_SOCKET_CLASS = "Net::SSL";
Actually this should be $SSL_CLASS, not $SSL_SOCKET_CLASS. Show quoted text
> +} > +elsif ($IO::Socket::SSL::VERSION) { > $SSL_CLASS = "IO::Socket::SSL"; # it was already loaded > }
Patch applied in 5.806. But the correction did not make it until 5.807 :)


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.