Skip Menu |
 

This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id: 26055
Status: rejected
Priority: 0/
Queue: Module-Install

People
Owner: Nobody in particular
Requestors: MTHURN [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Wishlist
Broken in: 0.65
Fixed in: (no value)



Subject: require a module LESS THAN a certain version
Download (untitled) / with headers
text/plain 392b
It would be *really nice* if it were possible to specify a prerequisite module not to exceed a certain version. For example, with ActivePerl build 820 on MSWin32, Compress::Zlib 2.001 is "broken" because of some weird interaction with Scalar::Util, but Compress::Zlib 1.42 works fine. I would like to specify "requires Compress::Zlib < 2.0" in my Makefile.PL -- - - Martin 'Kingpin' Thurn
Download (untitled) / with headers
text/plain 100b
Unfortunately, I am limited by the underlying MakeMaker implementation, which does not support this.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.