Skip Menu |
 

This queue is for tickets about the DBD-Pg CPAN distribution.

Report information
The Basics
Id: 25759
Status: resolved
Priority: 0/
Queue: DBD-Pg

People
Owner: Nobody in particular
Requestors: jmuhlich [...] bitflood.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: 2.0.0



Subject: META.yml problems
Date: Sat, 24 Mar 2007 18:01:21 -0400
To: bug-dbd-pg [...] rt.cpan.org
From: Jeremy Muhlich <jmuhlich [...] bitflood.org>
Download (untitled) / with headers
text/plain 752b
In r7778, turnstep added this line to META.yml : --- #YAML:1.2 And in r9241 he changed that to: --- #YAML:1.3 I am no YAML expert, but YAML.pm's parser interprets that as the "YAML" directive, which indicates the version of YAML a document conforms to. The current official spec states that directives begin with %, but a preliminary (late 2002) version of the spec did use #. Anyway, YAML 1.2 and 1.3 aren't even defined yet, so I'm not sure what you're trying to notate. YAML.pm throws a nasty warning + stack trace during the build when it sees that line. DBD::Pg still builds, tests, and installs OK, but the warning might be frightening to some. Whatever you're trying to do there, I think you should use a different syntax. -- Jeremy
Download (untitled) / with headers
text/plain 369b
On Суб. Мар. 24 18:01:37 2007, jmuhlich@bitflood.org wrote: Show quoted text
> In r7778, turnstep added this line to META.yml : > > --- #YAML:1.2 > > And in r9241 he changed that to: > > --- #YAML:1.3
Correct way to generate META.yml is by `make dist`. This will automatically generate header --- #YAML:1.0 1.2/1.3 is version of META. -- Alexandr Ciornii, http://chorny.net
Download (untitled) / with headers
text/plain 440b
On Mar 24 18:01:37 2007, jmuhlich@bitflood.org wrote: Show quoted text
> In r7778, turnstep added this line to META.yml : > > --- #YAML:1.2 > > And in r9241 he changed that to: > > --- #YAML:1.3
Correct way to generate META.yml is by `make dist`. This will automatically generate header --- #YAML:1.0 1.2/1.3 is version of META.yml spec, not YAML. See http://module-build.sourceforge.net/META-spec-current.html -- Alexandr Ciornii, http://chorny.net
Subject: Re: [rt.cpan.org #25759] META.yml problems
Date: Mon, 02 Apr 2007 10:42:28 -0400
To: bug-DBD-Pg [...] rt.cpan.org
From: Jeremy Muhlich <jmuhlich [...] bitflood.org>
Download (untitled) / with headers
text/plain 485b
Alexandr Ciornii via RT wrote: Show quoted text
> 1.2/1.3 is version of META.yml spec, not YAML. > See http://module-build.sourceforge.net/META-spec-current.html
Ah, good catch. See this section in particular: http://module-build.sourceforge.net/META-spec-current.html#metaspec Example: meta-spec: version: 1.3 url: http://module-build.sourceforge.net/META-spec-v1.3.html (Spec 1.1) [required] {URL} This field indicates the location of the version of the META.yml specification used.
Fixed in r9757 by changing to simply 1.0, thanks for the report.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.