This queue is for tickets about the CPAN CPAN distribution.

Report information
The Basics
Id:
2561
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
ANDK [...] cpan.org
Requestors:
bryan.thale [...] motorola.com
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
1.70
Fixed in:
(no value)



Subject: Bundle::CPAN v1.70 fails to build, can't find pod2man
I'm trying to upgrade from CPAN 1.61 to 1.70 on a RH 9.0 host with Perl 5.8.0. install Bundle::CPAN fails with a message that it couldn't find pod2man on the path. It looks like the POD2MAN_EXE line in the generated makefile is munged. It reads: POD2MAN_EXE = -S pod2man it should read: POD2MAN_EXE = /usr/bin/pod2man shouldn't it? Can I work around this by doing a make install in the CPAN-1.70 build directory outside of running a CPAN shell or will that screw up CPAN's view of which modules are installed?


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.