Skip Menu |
 

This queue is for tickets about the Data-Alias CPAN distribution.

Report information
The Basics
Id: 25551
Status: resolved
Priority: 0/
Queue: Data-Alias

People
Owner: xmath-no-spam [...] nospam.cpan.org
Requestors: cweyl [...] alumni.drew.edu
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: Compiler warnings on x86_64
Date: Mon, 19 Mar 2007 09:21:53 -0700
To: bug-Data-Alias [...] rt.cpan.org
From: "Chris Weyl" <cweyl [...] alumni.drew.edu>
Download (untitled) / with headers
text/plain 1.5k
Just built Data::Alias 1.03 on x86_64, and found various compiler warnings: gcc -c -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -Wdeclaration-after-statement -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -DVERSION=\"1.03\" -DXS_VERSION=\"1.03\" -fPIC "-I/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/CORE" Alias.c Alias.xs: In function 'DataAlias_pp_splice': Alias.xs:1074: warning: comparison is always false due to limited range of data type Alias.xs:1077: warning: comparison is always false due to limited range of data type Alias.xs:1082: warning: comparison is always false due to limited range of data type Alias.xs:1083: warning: comparison is always false due to limited range of data type Alias.xs: In function 'XS_Data__Alias_deref': Alias.xs:1836: warning: comparison is always false due to limited range of data type Alias.xs: In function 'boot_Data__Alias': Alias.xs:1777: warning: value computed is not used Alias.xs:1777: warning: value computed is not used rm -f blib/arch/auto/Data/Alias/Alias.so The module builds, etc, but looking at the parts of Alias.xs being warned, it looks as if this is warning about 32-bit data types. I haven't had my C hat on in a while :), but it looks to me as if this may indicate issues with this module under a 64-bit architecture? For reference, the system is FC6 on x86_64. "This is perl, v5.8.8 built for x86_64-linux-thread-multi" -Chris -- Chris Weyl Ex astris, scientia
Fixed in next release


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.