Skip Menu |
 

This queue is for tickets about the XML-LibXML CPAN distribution.

Report information
The Basics
Id: 25474
Status: resolved
Priority: 0/
Queue: XML-LibXML

People
Owner: Nobody in particular
Requestors: emileaben [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: Wishlist
Broken in: (no value)
Fixed in: (no value)



Subject: autosplit error on calling methods not in XML::LibXML
Download (untitled) / with headers
text/plain 731b
I made a typo when trying out XML::LibXML like this: use XML::LibXML; my $parser = XML::LibXML->new(); my $doc = $parser->parsefile($infile); ('parsefile' should have been 'parse_file' ). I got this error from that piece of code: Can't locate auto/XML/LibXML/parsefile.al in @INC (@INC contains: .... In retrospect I'd expected a "Can't locate object method 'parsefile' via XML::LibXML" type of error, since the error I got got me searching for all kinds of things that were wrong with my installation, instead of noticing my typo. I saw this behaviour at least on 2 different OSes: 1) XML::LibXML version 1.62 / perl5.8.7 / FreeBSD 5.4-RELEASE 2) XML::LibXML version 1.58 / perl5.8.7 / Linux 2.6.15-27-amd64-generic Emile
Subject: Re: [rt.cpan.org #25474] autosplit error on calling methods not in XML::LibXML
Date: Thu, 15 Mar 2007 20:16:29 +0100
To: bug-XML-LibXML [...] rt.cpan.org
From: Christian Glahn <christian.glahn [...] lo-f.at>
Download (untitled) / with headers
text/plain 1.4k
Sorry for the problems, Emile, but I fear this error is because XML::LibXML relies heavily on an perl-XS implementation (which cannot get changed at all). As far as I remember, XML::LibXML doesn't use any autoloader functions than the XS loader. Christian emileaben@gmail.com via RT wrote: Show quoted text
> Thu Mar 15 15:04:21 2007: Request 25474 was acted upon. > Transaction: Ticket created by emileaben@gmail.com > Queue: XML-LibXML > Subject: autosplit error on calling methods not in XML::LibXML > Broken in: (no value) > Severity: Wishlist > Owner: Nobody > Requestors: emileaben@gmail.com > Status: new > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=25474 > > > > I made a typo when trying out XML::LibXML like this: > > use XML::LibXML; > my $parser = XML::LibXML->new(); > my $doc = $parser->parsefile($infile); > > ('parsefile' should have been 'parse_file' ). I got this error from that > piece of code: > > Can't locate auto/XML/LibXML/parsefile.al in @INC (@INC contains: .... > > In retrospect I'd expected a "Can't locate object method 'parsefile' via > XML::LibXML" type of error, since the error I got got me searching for > all kinds of things that were wrong with my installation, instead of > noticing my typo. > > > I saw this behaviour at least on 2 different OSes: > > 1) XML::LibXML version 1.62 / perl5.8.7 / FreeBSD 5.4-RELEASE > 2) XML::LibXML version 1.58 / perl5.8.7 / Linux 2.6.15-27-amd64-generic > > Emile >
Download (untitled) / with headers
text/plain 293b
It seems that adding undef &AUTOLOAD; just after bootstrap XML::LibXML $VERSION in LibXML.pm does the job (still in the BEGIN section). I'll commit it to the SVN as soon as the SVN is up and running again:-) Unless someone finds problems with this solution, it'll appear in 1.63. -- Petr


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.