Skip Menu |
 

This queue is for tickets about the Encode CPAN distribution.

Report information
The Basics
Id: 25216
Status: resolved
Priority: 0/
Queue: Encode

People
Owner: Nobody in particular
Requestors: at [...] altlinux.ru
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: [PATCH] Encode.pm: postpone the load of Encode::Encoding
Date: Wed, 28 Feb 2007 15:49:59 +0300
To: bug-encode [...] rt.cpan.org
From: Alexey Tourbin <at [...] altlinux.ru>
Download (untitled) / with headers
text/plain 400b
--- Encode.pm | 2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/Encode.pm b/Encode.pm index d003cf2..17ca4aa 100644 --- a/Encode.pm +++ b/Encode.pm @@ -209,7 +209,7 @@ predefine_encodings(1); # sub predefine_encodings { - use Encode::Encoding; + require Encode::Encoding; no warnings 'redefine'; my $use_xs = shift; if ($ON_EBCDIC) { -- 1.5.0.1.GIT
Download (untitled) / with headers
text/plain 589b
I pretty much doubt if it saves anything but it does not hurt either so your patch is in. Dan the Encode Maintainer On Wed Feb 28 10:39:00 2007, at@altlinux.ru wrote: Show quoted text
> --- > Encode.pm | 2 +- > 1 files changed, 1 insertions(+), 1 deletions(-) > > diff --git a/Encode.pm b/Encode.pm > index d003cf2..17ca4aa 100644 > --- a/Encode.pm > +++ b/Encode.pm > @@ -209,7 +209,7 @@ predefine_encodings(1); > # > > sub predefine_encodings { > - use Encode::Encoding; > + require Encode::Encoding; > no warnings 'redefine'; > my $use_xs = shift; > if ($ON_EBCDIC) {
Download (untitled) / with headers
text/plain 218b
On Fri Apr 06 07:34:17 2007, DANKOGAI wrote: Show quoted text
> I pretty much doubt if it saves anything but it does not hurt either > so your patch is in.
This is also to brek circular dependency between Encode and Encode::Encoding.
Download (untitled) / with headers
text/plain 359b
On Sat Apr 07 10:38:52 2007, ATOURBIN wrote: Show quoted text
> On Fri Apr 06 07:34:17 2007, DANKOGAI wrote:
> > I pretty much doubt if it saves anything but it does not hurt either > > so your patch is in.
> > This is also to brek circular dependency between Encode and > Encode::Encoding.
I see. At any rate your patch is in 2.19. Closing RT. Dan the Encode Maintainer


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.