Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Perl-Dist-Strawberry CPAN distribution.

Report information
The Basics
Id:
25000
Status:
resolved
Priority:
Low/Low

People
Owner:
dagolden [...] cpan.org
Requestors:
Vijay.Anand [...] wonderware.com
larry [...] yudel.com
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
(no value)
Fixed in:
(no value)



Subject: bug in Perl-Dist-Strawberry : CPAN module compiles fail
Date: Thu, 7 Dec 2006 21:24:55 -0800
To: <bug-Perl-Dist-Strawberry@rt.cpan.org>
From: "Anand, Vijay" <Vijay.Anand@wonderware.com>
  • Distribution name and version : strawberry-perl-5.8.8-alpha-2.exe  
  • Perl version : perl, v5.8.8 built for MSWin32-x86-multi-thread
  • Operating System vendor and version : Microsoft Windows [Version 6.0.6000] : VISTA (MSDN) release , 64-bit

BUG: Include and LIB paths are incomplete/incorrect.  CPAN modules that require compilation fail to compile.

 

More detail – error messages, and workaround are posted at :

   http://perlmonks.org/?node_id=588243

Note: My PC (Like most Windows installs) did not have a c compiler, and depended on the gcc installed by Strawberry perl.

However, the include and lib files required to compile CPAN distributions were not available/configured at module compile time.

 

I made a very crude hack to get my system working. I believe a simpler, more elegant, “proper” fix should be distributed to the community.

 

Thank you for creating and working on this perl distribution.

 

-perlmonk “NetWallah”.

This looks like a problem with PATH, LIB and INCLUDE not being set properly. The installer needs to be smarter about this and warn the user if it can't make these changes.
Subject: Fails to set path on installation
Date: Fri, 16 Feb 2007 12:09:46 -0500
To: bug-Perl-Dist-Strawberry@rt.cpan.org
From: "Larry Yudelson" <larry@yudel.com>
Version: 5.8.8. alpha 2
 
After installing, CPAN didn't work... because the paths weren't added.
 
So I created the following bat file (c:\straberry-perl\strawberry-setup.bat) :
 
 
set PATH=C:\strawberry-perl\perl\bin;C:\strawberry-perl\dmake\bin;C:\strawberry-perl\mingw;C:\strawberry-perl\mingw\bin;%PATH%
set LIB=C:\strawberry-perl\mingw\lib;C:\strawberry-perl\perl\bin
set INCLUDE=C:\strawberry-perl\mingw\include;C:\strawberry-perl\perl\lib\CORE;C:\strawberry-perl\perl\lib\encode
 

Running the bat file fixed the problem.
 
I recommend adding this bat file into the distribution. It could be added to the startup folder, either automatically or manually.
 

--
Larry Yudelson
Editorial Director
Ben Yehuda Press
http://www.BenYehudaPress.com
----------------------------------------------------
"Torah and Company is wonderfully conceived
and wisely executed." -Joseph Telushkin,
winner of the 2006 National Jewish Book Award
http://tinyurl.com/26mnqy
On Fri Feb 16 12:10:04 2007, larry@yudel.com wrote:
Show quoted text
> Version: 5.8.8. alpha 2 > > After installing, CPAN didn't work... because the paths weren't added. > > So I created the following bat file (c:\straberry-perl\strawberry- > setup.bat)
Strawberry usually sets those on install, but I'm getting some reports that it isn't always. What version of Windows are your running? When you ran the install file, did the logged-in username have Administrator privileges? Thanks, David
On Sat Feb 17 08:35:01 2007, DAGOLDEN wrote:
Show quoted text
> Strawberry usually sets those on install, but I'm getting some reports > that it isn't always. What version of Windows are your running? When > you ran the install file, did the logged-in username have Administrator > privileges?
Some research suggests this is a problem caused by the more restrictive user access control settings in Windows Vista. Changes/updates to the installer program will be necessary.


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.