Skip Menu |
 

This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id: 24769
Status: resolved
Priority: 0/
Queue: Module-Install

People
Owner: Nobody in particular
Requestors: TELS [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.64
Fixed in: (no value)



Subject: from_all fails for perl version (cannot handle "require vX.Y.Z")
Download (untitled) / with headers
text/plain 380b
Moin, when a .pm file has this line: require v5.6.2; the following appears: Cannot determine perl version info from lib/Math/BigRat.pm Changing this line to the (should be) equivalent: use v5.6.2; the Makefile.PL works correctly. In addition, no matter wether you use "use" or "require", the determined Perl version is not added to the META.yml file. best wishes, Tels
Download (untitled) / with headers
text/plain 526b
Hi. This has been fixed sometime before, so I closed. Thanks. On 2007-2-03 Sat 06:57:42, TELS wrote: Show quoted text
> Moin, > > when a .pm file has this line: > > require v5.6.2; > > the following appears: > > Cannot determine perl version info from lib/Math/BigRat.pm > > Changing this line to the (should be) equivalent: > > use v5.6.2; > > the Makefile.PL works correctly. In addition, no matter wether you use > "use" or "require", the determined Perl version is not added to the > META.yml file. > > best wishes, > > Tels


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.