Skip Menu |
 

This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id: 24194
Status: resolved
Priority: 0/
Queue: Module-Install

People
Owner: Nobody in particular
Requestors: RSAVAGE [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 0.64
Fixed in: (no value)



Subject: Error msg: Your installer Makefile.PL has a modification time in the future
Download (untitled) / with headers
text/plain 875b
Note: This is not the same problem as reported by David Golden in rt bug 23490. OS: Win2K. The error message is 'Your installer Makefile.PL has a modification time in the future'. The problem is discussed at great length in the docs for the module Win32::UTCFileTime. Suffice to say here only that this patch resolves the issue. Note: This patch applies to the version of Module::Install shipped in the inc directory. You might like to apply it to the version shipped in the lib directory, too. I did not try that. --- Install.pm.bak Wed Jan 3 06:03:55 2007 +++ Install.pm Wed Jan 3 06:03:59 2007 @@ -29,6 +29,8 @@ # releases once we can make sure it won't clash with custom # Module::Install extensions. $VERSION = '0.64'; + + require 'Win32/UTCFileTime.pm' if ($^O eq 'MSWin32'); } # Whether or not inc::Module::Install is actually loaded, the
Download (untitled) / with headers
text/plain 1.1k
Hi. Applied a modified version of your patch in the trunk (the reason of modification is M::I must work with Perl 5.5 (Win32::UTCFileTime only works with 5.6+), and we shouldn't depend on a non-cross-platform XS module). Thanks. On 2007-1-03 Wed 01:24:26, RSAVAGE wrote: Show quoted text
> Note: This is not the same problem as reported by David Golden in rt
bug Show quoted text
> 23490. > > OS: Win2K. > > The error message is 'Your installer Makefile.PL has a modification
time Show quoted text
> in the future'. > > The problem is discussed at great length in the docs for the module > Win32::UTCFileTime. Suffice to say here only that this patch resolves > the issue. > > Note: This patch applies to the version of Module::Install shipped in > the inc directory. You might like to apply it to the version shipped
in Show quoted text
> the lib directory, too. I did not try that. > > --- Install.pm.bak Wed Jan 3 06:03:55 2007 > +++ Install.pm Wed Jan 3 06:03:59 2007 > @@ -29,6 +29,8 @@ > # releases once we can make sure it won't clash with custom > # Module::Install extensions. > $VERSION = '0.64'; > + > + require 'Win32/UTCFileTime.pm' if ($^O eq 'MSWin32'); > } > > # Whether or not inc::Module::Install is actually loaded, the
Hi. 0.95 is out. If you still have the problem, reopen this. Thanks.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.