Skip Menu |
 

This queue is for tickets about the XML-Twig CPAN distribution.

Report information
The Basics
Id: 24145
Status: resolved
Priority: 0/
Queue: XML-Twig

People
Owner: MIROD [...] cpan.org
Requestors: dha [...] panix.com
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 3.28
Fixed in: (no value)



Subject: t/test_bugs_3_22.t fails on OS X 10.4.8 (intel)/perl 5.8.8
Tests go haywire about halfway through. output of prove -bv attached.
Subject: test.out
Download test.out
application/octet-stream 879b

Message body not shown because it is not plain text.

Download (untitled) / with headers
text/plain 642b
On Fri Dec 29 14:16:14 2006, dha@panix.com wrote: Show quoted text
> Tests go haywire about halfway through. output of prove -bv attached.
This is weird. I test the module on an intel mac before releasing it. It's on 5.8.6, but there should be no change with 5.8.8 (I also test on linux with 5.8.8). Could you send me the result of t/zz_dump_config.t to see what kind of config you have? It might be a case of a newer version of HTML::TreeBuilder outputting non-well-formed XML through the as_XML method (XML::Twig uses HTML::TreeBuilder to convert HTML to XML). Could you try with the development version at http://xmltwig.com/xmltwig/ Thanks __ mirod
Subject: Re: [rt.cpan.org #24145] t/test_bugs_3_22.t fails on OS X 10.4.8 (intel)/perl 5.8.8
Date: Sat, 30 Dec 2006 00:07:42 -0500
To: via RT <bug-XML-Twig [...] rt.cpan.org>
From: "David H. Adler" <dha [...] panix.com>
Download (untitled) / with headers
text/plain 984b
On Fri, Dec 29, 2006 at 05:21:13PM -0500, via RT wrote: Show quoted text
> > <URL: http://rt.cpan.org/Ticket/Display.html?id=24145 > > > On Fri Dec 29 14:16:14 2006, dha@panix.com wrote:
> > Tests go haywire about halfway through. output of prove -bv attached.
> > This is weird. I test the module on an intel mac before releasing it. > It's on 5.8.6, but there should be no change with 5.8.8 (I also test on > linux with 5.8.8). > > Could you send me the result of t/zz_dump_config.t to see what kind of > config you have?
attached. Show quoted text
> It might be a case of a newer version of HTML::TreeBuilder outputting > non-well-formed XML through the as_XML method (XML::Twig uses > HTML::TreeBuilder to convert HTML to XML). > > Could you try with the development version at http://xmltwig.com/xmltwig/
The devel version seems to test fine. wacky. thanks. dha -- David H. Adler - <dha@panix.com> - http://www.panix.com/~dha/ "Look, vultures! My dress is made of steaks!" - Allison Drennan
Download config.dump
text/plain 1.4k

Message body is not shown because sender requested not to inline it.



This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.