Skip Menu |
 

This queue is for tickets about the Catalyst-View-XSLT CPAN distribution.

Report information
The Basics
Id: 23976
Status: resolved
Worked: 20 min
Priority: 0/
Queue: Catalyst-View-XSLT

People
Owner: marting [...] cpan.org
Requestors: janus [...] errornet.de
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in:
  • 0.01
  • 0.02
Fixed in: (no value)



Subject: missing dependent module and wrong error message
Download (untitled) / with headers
text/plain 364b
Catalyst::View::XSLT isn't usable without adding UNIVERSAL::require or it would require additional adjustment to get it work. This is why the patch changes Catalyst::View::XSLT::XML::LibXSLT. Besides there's a mistake in the constructor that avoids expanding the error message; fixed too. Beforehand this led to failing tests and other misbehaviour, now working.
Subject: p5-Catalyst-View-XSLT-0.02p0.diff
Index: Makefile =================================================================== RCS file: /cvs/ports/textproc/p5-Catalyst-View-XSLT/Makefile,v retrieving revision 1.1.1.1 diff -u -r1.1.1.1 Makefile --- Makefile 7 Nov 2006 18:19:25 -0000 1.1.1.1 +++ Makefile 17 Dec 2006 15:55:16 -0000 @@ -2,27 +2,23 @@ COMMENT= "XSLT Views for catalyst" +MODULES= cpan DISTNAME= Catalyst-View-XSLT-0.02 -PKGNAME= p5-${DISTNAME} -CATEGORIES= textproc perl5 +PKGNAME= p5-${DISTNAME}p0 +CATEGORIES= textproc -# Artistic + GPL +# Perl PERMIT_PACKAGE_CDROM= Yes PERMIT_PACKAGE_FTP= Yes PERMIT_DISTFILES_CDROM= Yes PERMIT_DISTFILES_FTP= Yes -MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Catalyst/} - RUN_DEPENDS= :p5-XML-LibXSLT->=1.60:textproc/p5-XML-LibXSLT \ - ::www/p5-Catalyst-Runtime -REGRESS_DEPENDS=${RUN_DEPENDS} \ - ::devel/p5-Test-Pod \ - ::devel/p5-Test-Pod-Coverage + ::www/p5-Catalyst-Runtime \ + ::devel/p5-Universal-require MAKE_ENV= TEST_POD=Yes -CONFIGURE_STYLE=perl modbuild -PKG_ARCH= * +CONFIGURE_STYLE=modbuild .include <bsd.port.mk> Index: patches/patch-lib_Catalyst_View_XSLT_XML_LibXSLT_pm =================================================================== RCS file: /cvs/ports/textproc/p5-Catalyst-View-XSLT/patches/patch-lib_Catalyst_View_XSLT_XML_LibXSLT_pm,v retrieving revision 1.1.1.1 diff -u -r1.1.1.1 patch-lib_Catalyst_View_XSLT_XML_LibXSLT_pm --- patches/patch-lib_Catalyst_View_XSLT_XML_LibXSLT_pm 7 Nov 2006 18:19:25 -0000 1.1.1.1 +++ patches/patch-lib_Catalyst_View_XSLT_XML_LibXSLT_pm 17 Dec 2006 15:55:16 -0000 @@ -1,7 +1,15 @@ $OpenBSD: patch-lib_Catalyst_View_XSLT_XML_LibXSLT_pm,v 1.1.1.1 2006/11/07 18:19:25 espie Exp $ ---- lib/Catalyst/View/XSLT/XML/LibXSLT.pm.orig Mon Nov 6 18:15:59 2006 -+++ lib/Catalyst/View/XSLT/XML/LibXSLT.pm Mon Nov 6 18:16:18 2006 -@@ -37,7 +37,7 @@ sub new +--- lib/Catalyst/View/XSLT/XML/LibXSLT.pm.orig Tue Feb 21 11:56:24 2006 ++++ lib/Catalyst/View/XSLT/XML/LibXSLT.pm Sun Dec 17 16:55:33 2006 +@@ -2,6 +2,7 @@ package Catalyst::View::XSLT::XML::LibXS + + use strict; + use warnings; ++use UNIVERSAL::require; + + =head1 NAME + +@@ -37,7 +38,7 @@ sub new }; if ($@) {
From: janus [...] errornet.de
Download (untitled) / with headers
text/plain 471b
On Mon Dec 18 04:08:42 2006, janus wrote: Show quoted text
> Catalyst::View::XSLT isn't usable without adding UNIVERSAL::require or > it would require additional adjustment to get it work. > This is why the patch changes Catalyst::View::XSLT::XML::LibXSLT. > Besides there's a mistake in the constructor that avoids expanding the > error message; fixed too. > > Beforehand this led to failing tests and other misbehaviour, now working.
Oops, wrong patch attached, here's the actual one.
Index: lib/Catalyst/View/XSLT/XML/LibXSLT.pm =================================================================== --- lib/Catalyst/View/XSLT/XML/LibXSLT.pm (revision 5870) +++ lib/Catalyst/View/XSLT/XML/LibXSLT.pm (working copy) @@ -2,6 +2,7 @@ use strict; use warnings; +use UNIVERSAL::require; =head1 NAME @@ -37,7 +38,7 @@ }; if ($@) { - $c->error('Could not use XML::LibXSLT: $@'); + $c->error('Could not use XML::LibXSLT: ' . $@); return undef; }
From: janus [...] errornet.de
Download (untitled) / with headers
text/plain 594b
On Mon Dec 18 04:13:02 2006, janus wrote: Show quoted text
> On Mon Dec 18 04:08:42 2006, janus wrote:
> > Catalyst::View::XSLT isn't usable without adding UNIVERSAL::require or > > it would require additional adjustment to get it work. > > This is why the patch changes Catalyst::View::XSLT::XML::LibXSLT. > > Besides there's a mistake in the constructor that avoids expanding the > > error message; fixed too. > > > > Beforehand this led to failing tests and other misbehaviour, now
working. Show quoted text
> > Oops, wrong patch attached, here's the actual one.
I updated my previous patch to add the require to Build.PL.
Index: lib/Catalyst/View/XSLT/XML/LibXSLT.pm =================================================================== --- lib/Catalyst/View/XSLT/XML/LibXSLT.pm (revision 5870) +++ lib/Catalyst/View/XSLT/XML/LibXSLT.pm (working copy) @@ -2,6 +2,7 @@ use strict; use warnings; +use UNIVERSAL::require; =head1 NAME @@ -37,7 +38,7 @@ }; if ($@) { - $c->error('Could not use XML::LibXSLT: $@'); + $c->error('Could not use XML::LibXSLT: ' . $@); return undef; } Index: Build.PL =================================================================== --- Build.PL (revision 5870) +++ Build.PL (working copy) @@ -10,6 +10,7 @@ 'File::Spec' => 3.10, 'Data::Dumper' => 2.00, 'Path::Class' => 0.12, + 'UNIVERSAL::require' => 0, }, build_requires => { 'Test::More' => 0.60,
From: Martin Grigorov
Download (untitled) / with headers
text/plain 762b
On Mon Dec 18 05:31:34 2006, janus wrote: Show quoted text
> On Mon Dec 18 04:13:02 2006, janus wrote:
> > On Mon Dec 18 04:08:42 2006, janus wrote:
> > > Catalyst::View::XSLT isn't usable without adding UNIVERSAL::require or > > > it would require additional adjustment to get it work. > > > This is why the patch changes Catalyst::View::XSLT::XML::LibXSLT. > > > Besides there's a mistake in the constructor that avoids expanding the > > > error message; fixed too. > > > > > > Beforehand this led to failing tests and other misbehaviour, now
> working.
> > > > Oops, wrong patch attached, here's the actual one.
> > I updated my previous patch to add the require to Build.PL.
Hi Janus, Thanks for the feedback. The problems are fixed in version 0.03. Kind regards Martin
Hi, The problems are fixed in ver. 0.03 Kind regards Martin
Subject: Re: [rt.cpan.org #23976] missing dependent module and wrong error message
Date: Thu, 21 Dec 2006 09:00:23 +0100
To: Martin Grigorov via RT <bug-Catalyst-View-XSLT [...] rt.cpan.org>
From: Simon Dassow <janus [...] errornet.de>
Download (untitled) / with headers
text/plain 331b
On Thu, Dec 21, 2006 at 02:30:13AM -0500, Martin Grigorov via RT wrote: Show quoted text
> > <URL: http://rt.cpan.org/Ticket/Display.html?id=23976 > > > Hi, > > The problems are fixed in ver. 0.03 >
Yeah... i've already prepared an updated port for it, so OpenBSD will have a fixed version this week, thank you very much. Kind regards, Simon
Download (untitled) / with headers
text/plain 132b
Oops, my answer reopened the bug, now closing it again. And by the way, the mentioned port for OpenBSD was imported in the meantime.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.