Skip Menu |
 

This queue is for tickets about the Bundle-CPAN CPAN distribution.

Report information
The Basics
Id: 23615
Status: new
Priority: 0/
Queue: Bundle-CPAN

People
Owner: Nobody in particular
Requestors: chhalling [...] verizon.net
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 1.854
Fixed in: (no value)



Subject: Doesn't install Compress::Zlib or Archive::Zip
Download (untitled) / with headers
text/plain 969b
For Mac OS X 10.4.8. I installed Perl 5.8.8 into /test/perl directory using these commands: sudo rm -rf /test sudo mkdir /test cd /Volumes/CHHalling/Perl/Perl-5.8.8/perl-5.8.8 make distclean sh Configure -Dprefix=/test/perl -Dcc=gcc -des make sudo make install export PATH=/test/perl/bin:$PATH I attempted to install Bundle::CPAN: cd ~ sudo rm -rf .cpan sudo cpan Show quoted text
cpan> install Test::Pod cpan> install Test::Pod::Coverage cpan> install Bundle::CPAN
At the end of the installation, two modules, Compress::Zlib and Archive::Zip, were not installed. I had to install these manually: Show quoted text
cpan> install Compress::Zlib cpan> install Archive::Zip
I have attached the entire log file of the installation. It looks like CPAN gets confused about dependencies (not your fault). Perhaps the solution is to change the Bundle::CPAN file to install IO::Compress::Base, IO::Compress::Zlib, and Compress::Raw::Zlib before installing Compress::Zlib and Archive::Zip.
Subject: cpan.log
Download cpan.log
application/octet-stream 219.9k

Message body not shown because it is not plain text.



This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.