Skip Menu |
 

This queue is for tickets about the Module-Build CPAN distribution.

Report information
The Basics
Id: 2305
Status: resolved
Priority: 0/
Queue: Module-Build

People
Owner: Nobody in particular
Requestors:
Cc:
AdminCc:

Bug Information
Severity: Unimportant
Broken in: 0.01
Fixed in: (no value)



Subject: Prereq warnings don't distinguish between required & optional prereqs
Download (untitled) / with headers
text/plain 335b
Even when some modules are optional, the look like they're required. For example: WARNING: YAML: Prerequisite YAML isn't installed WARNING: ExtUtils::ParseXS: Prerequisite ExtUtils::ParseXS isn't installed WARNING: Archive::Tar: Prerequisite Archive::Tar isn't installed All of those are merely 'recommends' prerequisites for M::B.
Fixed in beta release 0.21_01


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.