Skip Menu |
 

This queue is for tickets about the Perl-MinimumVersion CPAN distribution.

Report information
The Basics
Id: 22770
Status: resolved
Priority: 0/
Queue: Perl-MinimumVersion

People
Owner: Nobody in particular
Requestors: GHENRY [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 0.13
Fixed in: (no value)



Subject: Test 02_main.t fails
Download (untitled) / with headers
text/plain 3.4k
Perl-MinimumVersion-0.13/ Perl-MinimumVersion-0.13/inc/ Perl-MinimumVersion-0.13/inc/Module/ Perl-MinimumVersion-0.13/inc/Module/Install.pm Perl-MinimumVersion-0.13/inc/Module/Install/ Perl-MinimumVersion-0.13/inc/Module/Install/AutoInstall.pm Perl-MinimumVersion-0.13/inc/Module/Install/Fetch.pm Perl-MinimumVersion-0.13/inc/Module/Install/Makefile.pm Perl-MinimumVersion-0.13/inc/Module/Install/Include.pm Perl-MinimumVersion-0.13/inc/Module/Install/Scripts.pm Perl-MinimumVersion-0.13/inc/Module/Install/Base.pm Perl-MinimumVersion-0.13/inc/Module/Install/Metadata.pm Perl-MinimumVersion-0.13/inc/Module/Install/Can.pm Perl-MinimumVersion-0.13/inc/Module/Install/WriteAll.pm Perl-MinimumVersion-0.13/inc/Module/Install/Win32.pm Perl-MinimumVersion-0.13/inc/Module/AutoInstall.pm Perl-MinimumVersion-0.13/Changes Perl-MinimumVersion-0.13/MANIFEST Perl-MinimumVersion-0.13/bin/ Perl-MinimumVersion-0.13/bin/perlver Perl-MinimumVersion-0.13/t/ Perl-MinimumVersion-0.13/t/99_pod.t Perl-MinimumVersion-0.13/t/02_main.t Perl-MinimumVersion-0.13/t/01_compile.t Perl-MinimumVersion-0.13/META.yml Perl-MinimumVersion-0.13/lib/ Perl-MinimumVersion-0.13/lib/Perl/ Perl-MinimumVersion-0.13/lib/Perl/MinimumVersion.pm Perl-MinimumVersion-0.13/README Perl-MinimumVersion-0.13/LICENSE Perl-MinimumVersion-0.13/Makefile.PL Package came without SIGNATURE CPAN.pm: Going to build A/AD/ADAMK/Perl-MinimumVersion-0.13.tar.gz *** Module::AutoInstall version 1.02 *** Checking for Perl dependencies... [Core Features] - Test::More ...loaded. (0.64 >= 0.47) - File::Spec ...loaded. (3.19 >= 0.80) - Carp ...loaded. (1.04) - version ...loaded. (0.640 >= 0.59) - List::Util ...loaded. (1.180 >= 1.17) - Params::Util ...loaded. (0.140 >= 0.06) - File::Find::Rule ...loaded. (0.300) - PPI ...loaded. (1.118 >= 1.109) *** Module::AutoInstall configuration finished. Checking if your kit is complete... Looks good Writing Makefile for Perl::MinimumVersion CPAN: YAML loaded ok cp lib/Perl/MinimumVersion.pm blib/lib/Perl/MinimumVersion.pm cp bin/perlver blib/script/perlver /usr/bin/perl "-Iinc" "-MExtUtils::MY" -e "MY->fixin(shift)" blib/script/perlver Manifying blib/man1/perlver.1 Manifying blib/man3/Perl::MinimumVersion.3pm /usr/bin/make -- OK Running make test PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'inc', 'blib/lib', 'blib/arch')" t/01_compile.t t/02_main.t t/99_pod.t t/01_compile....ok t/02_main.......NOK 46 # Failed test 'utf8 module makes the version 5.008' # in t/02_main.t at line 32. # got: '5.004' # expected: '5.008' # Looks like you failed 1 test of 46. t/02_main.......dubious Test returned status 1 (wstat 256, 0x100) DIED. FAILED test 46 Failed 1/46 tests, 97.83% okay t/99_pod........ok Failed Test Stat Wstat Total Fail Failed List of Failed ------------------------------------------------------------------------------- t/02_main.t 1 256 46 1 2.17% 46 Failed 1/3 test scripts, 66.67% okay. 1/50 subtests failed, 98.00% okay. make: *** [test_dynamic] Error 255 /usr/bin/make test -- NOT OK Running make install make test had returned bad status, won't install without force [root@blackhat ~]# vi ~/.cpan/build/Perl-MinimumVersion-0.13/t/02_main.t [root@blackhat ~]# cpan PPI CPAN: File::HomeDir loaded ok CPAN: Storable loaded ok Going to read /root/.cpan/Metadata Database was generated on Thu, 02 Nov 2006 01:24:37 GMT PPI is up to date (1.118).


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.