Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the CGI CPAN distribution.

Report information
The Basics
Id: 22737
Status: resolved
Priority: 0/
Queue: CGI

People
Owner: MARKSTOS [...] cpan.org
Requestors: john [...] redux.org.uk
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: (no value)
Fixed in: (no value)



Subject: multipart_start doesn't accept a -charset parameter
Download (untitled) / with headers
text/plain 767b
I was recently investigating a bug in the development Bugzilla, and discovered the problem was caused by CGI.pm's multipart_start() not accepting a -charset parameter. This meant that is was impossible to specify a UTF-8 multipart (without putting the charset in the content type). So, I provided a patch to Bugzilla to modify their Bugzilla::CGI::multipart_start() to accept -charset. This was provided in https://bugzilla.mozilla.org/show_bug.cgi?id=357526 and subsequently checked in: http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/webtools/bugzilla/Bugzilla&command=DIFF_FRAMESET&file=CGI.pm&rev1=1.29&rev2=1.30&root=/cvsroot It was suggested that this bug was reported upstream, so here it is... Cheers, John.
Download (untitled) / with headers
text/plain 1.1k
On Wed Nov 01 07:12:03 2006, jberanek wrote: Show quoted text
> > I was recently investigating a bug in the development Bugzilla, and > discovered the problem was caused by CGI.pm's multipart_start() not > accepting a -charset parameter. This meant that is was impossible to > specify a UTF-8 multipart (without putting the charset in the content > type). > > So, I provided a patch to Bugzilla to modify their > Bugzilla::CGI::multipart_start() to accept -charset. This was provided > in https://bugzilla.mozilla.org/show_bug.cgi?id=357526 and > subsequently > checked in: >
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/webtools/bugzilla/Bugzilla&command=DIFF_FRAMESET&file=CGI.pm&rev1=1.29&rev2=1.30&root=/cvsroot Show quoted text
> > It was suggested that this bug was reported upstream, so here it is...
John, I agree with this change request. Could you submit a "diff -u" against CGI.pm 3.43, which also contains an automated test to confirm this change, as well as a patch to documentation which exposes it? I would like this change to appear in the next release, with credit to you. Thanks for the patch! Mark
Download (untitled) / with headers
text/plain 240b
This issue has been copied to: https://github.com/leejo/CGI.pm/issues/48 please take all future correspondence there. This ticket will remain open but please do not reply here. This ticket will be closed when the github issue is dealt with.
Download (untitled) / with headers
text/plain 501b
Patched, will go out in the next few days. Thanks! commit c83df6587ad5eba9454c8bc0930a655773bcc208 Author: Lee Johnson <lee@givengain.ch> Date: Fri Jun 6 16:51:50 2014 +0200 resolve #48 [rt.cpan.org #22737] - support charset in both multipart_start and multipart_init methods. add and update tests, perldoc, and example script to demonstrate this references: - https://rt.cpan.org/Ticket/Display.html?id=22737 - https://bugzilla.mozilla.org/show_bug.cgi?id=357526


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.