Skip Menu |
 

This queue is for tickets about the PAR CPAN distribution.

Report information
The Basics
Id: 22538
Status: new
Priority: 0/
Queue: PAR

People
Owner: Nobody in particular
Requestors: rumen [...] skyarchive.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: PAR - No such file or directory at -e line 761 PART II
Date: Tue, 24 Oct 2006 17:56:44 +0300
To: bug-PAR [...] rt.cpan.org
From: "Rumen Bogdanovski" <rumen [...] skyarchive.org>
Download (untitled) / with headers
text/plain 1.8k
Hi Steffen the problem turned to be more complicated than I previously thought. I found that on my development machine links do not work. bash-2.05b$ perl -MPAR -e'print PAR->VERSION."\n";' 0.956 bash-2.05b$ t.pl Executed t.pl - ./t.pl bash-2.05b$ t2.pl Executed t2.pl - ./t2.pl bash-2.05b$ pp -o t t.pl t2.pl bash-2.05b$ t Executed t.pl - /home/rumen/test/TT/t bash-2.05b$ ln -s t t2 bash-2.05b$ t2 Executed t.pl - /home/rumen/test/TT/t I decied to prepare a fresh installation of the same Slackware without perl. I have copied "photclient" a par executable prepared on the other machine. rumen@bc2s:~$ photclient **** PerlTK Window!!! **** rumen@bc2s:~$ ln -s photclient photview rumen@bc2s:~$ photview **** photclient window appeared!!!!! **** rumen@bc2s:~$ rm photview rumen@bc2s:~$ cp photclient photview rumen@bc2s:~$ photview ***** WORKS FINE now!!!! ***** Decied to install perl and PAR on the new machine and test whether it works if the binary is created on it: rumen@bc2s:~$ pp -o t t.pl t2.pl rumen@bc2s:~$ t No such file or directory at -e line 761 rumen@bc2s:~$ su Password: root@bc2s:/home/rumen# pp -o t t.pl t2.pl root@bc2s:/home/rumen# t Executed t.pl - /home/rumen/test/TT/t root@bc2s:/home/rumen# rm t root@bc2s:/home/rumen# exit exit rumen@bc2s:~$ pp -o t t.pl t2.pl rumen@bc2s:~$ t Executed t.pl - /home/rumen/test/TT/t rumen@bc2s:~$ I have tried "photclient" (a par executable) prepared on first machine (the same one that worked before): rumen@bc2s:~$ photclient No such file or directory at -e line 761. rumen@bc2s:~$ su Password: root@bc2s:/home/rumen# photclient ****** Perl/TK window appeared! ****** root@bc2s:/home/rumen# exit exit rumen@bc2s:~$ photclient ****** Perl/TK window appeared! ****** I could reproduce the same bug on Sparc/Solaris 10. Nasty isn't it :( I have lost 2 days dealing with this.... :( Can you help! Rumen


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.