Skip Menu |
 

This queue is for tickets about the Test-Harness CPAN distribution.

Report information
The Basics
Id: 21918
Status: resolved
Priority: 0/
Queue: Test-Harness

People
Owner: Nobody in particular
Requestors: daniel [...] crisman.org
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in:
  • 2.40
  • 2.41_01
  • 2.41_02
  • 2.42
  • 2.43_01
  • 2.43_02
  • 2.44
  • 2.45_01
  • 2.45_02
  • 2.46
  • 2.47_01
  • 2.47_02
  • 2.47_03
  • 2.48
  • 2.49_01
  • 2.49_02
  • 2.50
  • 2.51_02
  • 2.52
  • 2.53_01
  • 2.53_02
  • 2.54
  • 2.56
  • 2.57_01
  • 2.57_02
  • 2.57_03
  • 2.57_04
  • 2.57_05
  • 2.57_06
  • 2.58
  • 2.60
  • 2.62
  • 2.63_01
  • 2.63_02
Fixed in: (no value)



Subject: prove $VERSION out of date
Download (untitled) / with headers
text/plain 283b
The last time $VERSION in bin/prove was updated was around Test::Harness version 2.38, but there have been at least 5 changes (some major) since then. I recommend a major version bump to bin/prove version 2.000 p.s. This is probably the cause of some of the confusion in bug #21072
Fixed in 2.64. prove's $VERSION should always match the Test::Harness that it came with.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.