Skip Menu |
 

This queue is for tickets about the Parse-BACKPAN-Packages CPAN distribution.

Report information
The Basics
Id: 21759
Status: resolved
Priority: 0/
Queue: Parse-BACKPAN-Packages

People
Owner: Nobody in particular
Requestors: alexchorny [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: (no value)
Fixed in: (no value)



Subject: new version of Acme-Colour: 1.03
Download (untitled) / with headers
text/plain 359b
Tests fail in Parse::BACKPAN::Packages 0.32 # Failed test in t/simple.t at line 41. # got: 'Acme-Colour-1.03' # expected: 'Acme-Colour-1.02' As I understand, test downloads BACKPAN database. Please add a warning, because connection can be slow or somebody may have very limited traffic for month. ------- Alexandr Ciornii, http://chorny.net
Download (untitled) / with headers
text/plain 167b
It is interesting to look at http://cpantesters.perl.org/show/Parse-BACKPAN-Packages.html page. Only FAILs after certain id. -- Alexandr Ciornii, http://chorny.net
Download (untitled) / with headers
text/plain 160b
Attached is a patch to make t/simple.t less prone to failures whenever a new version of the Acme-Colour hits CPAN, or if maintainership of modules ever changes.
Download diff.patch
text/x-diff 3k
--- Parse-BACKPAN-Packages-0.33/t/simple.t Sun Jun 8 10:36:40 2008 +++ Parse-BACKPAN-Packages-0.34/t/simple.t Fri Jul 11 17:13:09 2008 @@ -1,7 +1,7 @@ #!perl use strict; use warnings; -use Test::More tests => 84; +use Test::More tests => 55; use lib 'lib'; use_ok("Parse::BACKPAN::Packages"); @@ -35,65 +35,42 @@ is($acme_colours[6]->version, "1.01"); is($acme_colours[7]->version, "1.02"); +# as the latest version may change at any time we only determine that the +# latest distribution is at least the last know version. +my $version = '1.04'; +my $latest = $acme_colours[-1]->version; +like($latest, qr/^\d+\.\d+$/); +cmp_ok($latest, '>=', $version); + is($acme_colours[-1]->cpanid, "LBROCARD"); -is($acme_colours[-1]->date, "1177770081"); +cmp_ok($acme_colours[-1]->date, '>=', "1177770081"); is($acme_colours[-1]->dist, "Acme-Colour"); -is($acme_colours[-1]->distvname, "Acme-Colour-1.04"); -is($acme_colours[-1]->filename, "Acme-Colour-1.04.tar.gz"); +is($acme_colours[-1]->distvname, "Acme-Colour-$latest"); +is($acme_colours[-1]->filename, "Acme-Colour-$latest.tar.gz"); is($acme_colours[-1]->maturity, "released"); -is($acme_colours[-1]->prefix, "authors/id/L/LB/LBROCARD/Acme-Colour-1.04.tar.gz"); -is($acme_colours[-1]->version, "1.04"); +is($acme_colours[-1]->prefix, "authors/id/L/LB/LBROCARD/Acme-Colour-$latest.tar.gz"); +# test a selection of owned distributions my @acmes = $p->distributions_by('LBROCARD'); foreach my $dist ( 'Acme-Colour', 'Buffy', - 'CPAN-IndexPod', - 'CPAN-Metadata-RDF', - 'CPAN-Unpack', - 'CPAN-WWW-Testers', - 'CPAN-WWW-Testers-Generator', - 'Data-Page', - 'DateTime-Stringify', 'Devel-ebug', 'Functional', 'Games-GuessWord', 'GraphViz', 'HTML-Fraction', 'HTTP-Server-Simple-Kwiki', - 'Haul', - 'Image-Imlib2', - 'Image-WorldMap', - 'Java-JVM-Classfile', - 'Language-Functional', - 'MP3-ID3Lib', - 'Mac-EyeTV', - 'MealMaster', - 'Messaging-Courier', - 'Module-Packaged', 'Net-Amazon-AWIS', 'Net-Amazon-SimpleQueue', 'Net-DPAP-Client', 'Net-OpenDHT', 'OpenFrame-Segment-Apache', 'OpenFrame-Segment-Apache2', - 'PPI-Metric-Basic', - 'Parse-BACKPAN-Packages', - 'Parse-CPAN-Authors', - 'Parse-CPAN-Packages', - 'Search-Mousse', - 'String-Koremutake', - 'Template-Plugin-Page', - 'Test-Expect', - 'Test-WWW-Mechanize-Catalyst', - 'Tie-GHash', - 'Tree-Ternary_XS', 'WWW-Gazetteer', 'WWW-Gazetteer-Calle', 'WWW-Gazetteer-FallingRain', 'WWW-Gazetteer-Getty', - 'WWW-Mechanize-Timed', - 'WWW-Search-Google', 'XML-asData', ) { ok(scalar(grep { $_ eq $dist } @acmes), "LBROCARD has $dist");
Thanks for the patch, Parse-BACKPAN-Packages-0.34.tar.gz just hit CPAN.
Fixed.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.