This queue is for tickets about the CPAN CPAN distribution.

Report information
The Basics
Id:
21724
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
adamk [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Wishlist
Broken in:
(no value)
Fixed in:
(no value)



Subject: Add support for regex upgrading
Having added the "upgrade" command, it's a bit scary to upgrade a zillion things at once. Further, if an Acme:: module fails to upgrade, you can't upgrade anything else. It would be nice if you could say (for example) "upgrade /Win32/" and it just upgraded the Win32:: modules.
Subject: Re: [rt.cpan.org #21724] Add support for regex upgrading
Date: Tue, 26 Sep 2006 13:13:53 +0200
To: bug-CPAN@rt.cpan.org
From: andreas.koenig.gmwojprw@franz.ak.mind.de (Andreas J. Koenig)
Show quoted text
>>>>> On Tue, 26 Sep 2006 03:11:12 -0400, " via RT" <bug-CPAN@rt.cpan.org> said:
Show quoted text
> Having added the "upgrade" command, it's a bit scary to upgrade a > zillion things at once. Further, if an Acme:: module fails to upgrade, > you can't upgrade anything else.
Is this really true (I cannot test right now)? I do not think so: I'd expect to get a decent list of all upgrades that failed with some hint about what failed at the end of the run. If you do not get such a list, please give me a hint how to reproduce, this is not the intended way of operation.
Show quoted text
> It would be nice if you could say (for example) "upgrade /Win32/" and it > just upgraded the Win32:: modules.
Very nice idea, will check how doable it is. -- andreas
Subject: Re: [rt.cpan.org #21724] Add support for regex upgrading
Date: Tue, 26 Sep 2006 20:48:03 +0200
To: bug-CPAN@rt.cpan.org
From: andreas.koenig.gmwojprw@franz.ak.mind.de (Andreas J. Koenig)
Show quoted text
>>>>> On Tue, 26 Sep 2006 07:14:20 -0400, "andreas.koenig.gmwojprw@franz.ak.mind.de via RT" <bug-CPAN@rt.cpan.org> said:
Show quoted text
> Queue: CPAN > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=21724 >
Show quoted text
>>>>> On Tue, 26 Sep 2006 03:11:12 -0400, " via RT" <bug-CPAN@rt.cpan.org> said:
Show quoted text
>> Having added the "upgrade" command, it's a bit scary to upgrade a >> zillion things at once. Further, if an Acme:: module fails to upgrade, >> you can't upgrade anything else.
Show quoted text
> Is this really true (I cannot test right now)?
Show quoted text
> I do not think so: I'd expect to get a decent list of all upgrades > that failed with some hint about what failed at the end of the run.
Show quoted text
> If you do not get such a list, please give me a hint how to reproduce, > this is not the intended way of operation.
For a demonstration, I just installed old versions of File::Slurp and Expect. Both modules currently have failing tests with bleadperl, so they would stop the upgrade marathon according to your words. I do have some other upgradeable modules as well. I say 'upgrade' Package namespace installed latest in CPAN file Expect 1.19 1.20 RGIERSIG/Expect-1.20.tar.gz ExtUtils::Manifest 1.46_01 1.48 RKOBES/ExtUtils-Manifest-1.48.tar.gz File::Slurp 9999.08 9999.12 URI/File-Slurp-9999.12.tar.gz Text::Soundex 1.01 3.02 MARKM/Text-Soundex-3.02.tar.gz threads 1.41 1.42 JDHEDDEN/threads-1.42.tar.gz threads::shared 0.94_01 1.03 JDHEDDEN/threads-shared-1.03.tar.gz version 0.67 0.6701 JPEACOCK/version-0.6701.tar.gz 61 installed modules have no parseable version number [...] Failed during this command: URI/File-Slurp-9999.12.tar.gz : make_test NO JPEACOCK/version-0.6701.tar.gz : make_test NO RGIERSIG/Expect-1.20.tar.gz : make_test NO You see, ExtUtils::Manifest, Text::Soundex and threads::{,shared} were installed successfully. No showstopper here.
Show quoted text
>> It would be nice if you could say (for example) "upgrade /Win32/" and it >> just upgraded the Win32:: modules.
Show quoted text
> Very nice idea, will check how doable it is.
This is amazing! Look, it's implemented with this tiny patch: Index: lib/CPAN.pm =================================================================== --- lib/CPAN.pm (revision 902) +++ lib/CPAN.pm (working copy) @@ -1698,8 +1698,8 @@ #-> sub CPAN::Shell::upgrade ; sub upgrade { - my($self) = shift @_; - $self->install($self->r); + my($self,@args) = @_; + $self->install($self->r(@args)); } #-> sub CPAN::Shell::_u_r_common ; and checked in as rev. 903. Thanks! -- andreas
Wish fulfilled in 1.88_51. Thanks!


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.