Skip Menu |
 

This queue is for tickets about the Test-Class CPAN distribution.

Report information
The Basics
Id: 2144
Status: resolved
Priority: 0/
Queue: Test-Class

People
Owner: Nobody in particular
Requestors: william [...] knowmad.com
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 0.03
Fixed in: 0.06_1



Subject: Install fails on t/pod.t at line 37
Download (untitled) / with headers
text/plain 905b
I am attempting to install Test::Class on a Debian 3.0 system using Perl 5.6.1. The t/pod.t test fails with the following output: t/pod..................NOK 1# Failed test (t/pod.t at line 37) # *** WARNING: multiple occurrence of link target 'Test::SimpleUnit' at line - in file /root/.cpan/build/Test-Class-0.03/t/../blib/lib/Test/Class.pm # *** WARNING: multiple occurrence of link target 'Test::Unit' at line - in file /root/.cpan/build/Test-Class-0.03/t/../blib/lib/Test/Class.pm # /root/.cpan/build/Test-Class-0.03/t/../blib/lib/Test/Class.pm pod syntax OK. # Looks like you failed 1 tests of 1. t/pod..................dubious Test returned status 1 (wstat 256, 0x100) DIED. FAILED test 1 Failed 1/1 tests, 0.00% okay I went ahead and did a force install but would like to have some resolution concerning this install error. Thanks!
Download (untitled) / with headers
text/plain 1.1k
First off, don't worry - the test failure just relates to the documentation, not the functionality of the module. Can you let me know the version of Pod::Checker you have installed, since the error is not showing on my version. Thanks. Adrian [guest - Sat Feb 22 14:22:27 2003]: Show quoted text
> I am attempting to install Test::Class on a Debian 3.0 system using > Perl 5.6.1. The t/pod.t test fails with the following output: > > t/pod..................NOK 1# Failed test (t/pod.t at line 37) > # *** WARNING: multiple occurrence of link target 'Test::SimpleUnit' > at line - in file /root/.cpan/build/Test-Class- > 0.03/t/../blib/lib/Test/Class.pm > # *** WARNING: multiple occurrence of link target 'Test::Unit' at line > - in file /root/.cpan/build/Test-Class- > 0.03/t/../blib/lib/Test/Class.pm > # /root/.cpan/build/Test-Class-0.03/t/../blib/lib/Test/Class.pm pod > syntax OK. > # Looks like you failed 1 tests of 1. > t/pod..................dubious > Test returned status 1 (wstat 256, 0x100) > DIED. FAILED test 1 > Failed 1/1 tests, 0.00% okay > > I went ahead and did a force install but would like to have some > resolution concerning this install error. > > Thanks!


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.