This queue is for tickets about the CPAN CPAN distribution.

Report information
The Basics
Id:
21317
Status:
resolved
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
ofun [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
1.76_01
Fixed in:
1.87



Subject: CPAN won't upgrade a module to its new version
I have version 2.4.2 of PDL.pm installed, and appear unable to upgrade to 2.4.3.
Show quoted text
cpan> m PDL
Module id = PDL DESCRIPTION Perl Data Language - numeric analysis env CPAN_USERID PERLDL (The Perl Data Language Mailing List <perldl@jach.hawaii.edu>) CPAN_VERSION 2.004003 CPAN_FILE C/CS/CSOE/PDL-2.4.3.tar.gz DSLI_STATUS amcf (alpha,mailing-list,C,functions) MANPAGE PDL - the Perl Data Language INST_FILE /Library/Perl/5.8.6/darwin-thread-multi-2level/PDL.pm INST_VERSION 2.4.2
Show quoted text
cpan> install PDL
PDL is up to date. The result is the same whether or not I run as root. My CPAN version data is: $ cpan --version /usr/bin/cpan version [unknown] calling Getopt::Std::getopts (version 1.05 [paranoid]), running under Perl version 5.8.6. [Now continuing due to backward compatibility and excessive paranoia. See ``perldoc Getopt::Std'' about $Getopt::Std::STANDARD_HELP_VERSION.] cpan shell -- CPAN exploration and modules installation (v1.7601) ReadLine support enabled My OS X version is 10.4.7 (PowerPC G4). Apologies if this is the fault of the PDL bundlers or my own user error. Thanks in advance for your help!
Subject: Re: [rt.cpan.org #21317] CPAN won't upgrade a module to its new version
Date: Mon, 04 Sep 2006 22:15:47 +0200
To: bug-CPAN@rt.cpan.org
From: andreas.koenig.gmwojprw@franz.ak.mind.de (Andreas J. Koenig)
Show quoted text
>>>>> On Mon, 04 Sep 2006 08:12:34 -0400, "Christopher D. Malon via RT" <bug-CPAN@rt.cpan.org> said:
Show quoted text
> Mon Sep 04 08:12:33 2006: Request 21317 was acted upon. > Transaction: Ticket created by OFUN > Queue: CPAN > Subject: CPAN won't upgrade a module to its new version > Broken in: 1.76_01 > Severity: Important > Owner: Nobody > Requestors: ofun@cpan.org > Status: new > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=21317 >
Show quoted text
> I have version 2.4.2 of PDL.pm installed, and appear unable to upgrade to 2.4.3.
Show quoted text
cpan> m PDL
Show quoted text
> Module id = PDL > DESCRIPTION Perl Data Language - numeric analysis env > CPAN_USERID PERLDL (The Perl Data Language Mailing List <perldl@jach.hawaii.edu>) > CPAN_VERSION 2.004003 > CPAN_FILE C/CS/CSOE/PDL-2.4.3.tar.gz > DSLI_STATUS amcf (alpha,mailing-list,C,functions) > MANPAGE PDL - the Perl Data Language > INST_FILE /Library/Perl/5.8.6/darwin-thread-multi-2level/PDL.pm > INST_VERSION 2.4.2
Show quoted text
cpan> install PDL
Show quoted text
> PDL is up to date.
Show quoted text
> The result is the same whether or not I run as root. My CPAN version data is:
Show quoted text
> $ cpan --version > /usr/bin/cpan version [unknown] calling Getopt::Std::getopts (version 1.05 [paranoid]), > running under Perl version 5.8.6. > [Now continuing due to backward compatibility and excessive paranoia. > See ``perldoc Getopt::Std'' about $Getopt::Std::STANDARD_HELP_VERSION.]
Show quoted text
> cpan shell -- CPAN exploration and modules installation (v1.7601) > ReadLine support enabled
Show quoted text
> My OS X version is 10.4.7 (PowerPC G4).
Show quoted text
> Apologies if this is the fault of the PDL bundlers or my own user error. > Thanks in advance for your help!
1.76_01 is now a bit old, current stable version is 1.87. Would it be asked too much that you upgrade? Between 1.7x and 1.8x the support for multidot version numbers was improved way big. During 1.7x support for multidot was always buggy because version.pm was not yet written. Just to prove what I say, I took 5.8.6-RC1 which I have lying around with CPAN.pm 1.83. With that I installed PDL 2.4.2 and then I could produce this:
Show quoted text
cpan> m PDL
Module id = PDL DESCRIPTION Perl Data Language - numeric analysis env CPAN_USERID PERLDL (The Perl Data Language Mailing List <perldl@jach.hawaii.edu>) CPAN_VERSION 2.004003 CPAN_FILE C/CS/CSOE/PDL-2.4.3.tar.gz UPLOAD_DATE 2006-08-20 DSLI_STATUS amcf (alpha,mailing-list,C,functions) MANPAGE PDL - the Perl Data Language INST_FILE /usr/local/perl-5.8.6-RC1/lib/site_perl/5.8.6/i686-linux-64int/PDL.pm INST_VERSION 2.4.2
Show quoted text
cpan> install PDL
Running install for module PDL Running make for C/CS/CSOE/PDL-2.4.3.tar.gz CPAN: checksum security checks disabled because Digest::SHA not installed. Please consider installing the Digest::SHA module. Caught SIGINT The SIGINT came from my keyboard:) If you cannot upgrade, you can work around this by saying
Show quoted text
cpan> install C/CS/CSOE/PDL-2.4.3.tar.gz
Thanks for your report & Regards, -- andreas
Subject: Re: Re: [rt.cpan.org #21317] CPAN won't upgrade a module to its new version
Date: Mon, 4 Sep 2006 21:10:43 -0400
To: bug-CPAN@rt.cpan.org
From: "Christopher Malon" <malon.cpan@gmail.com>
On 9/4/06, andreas.koenig.gmwojprw@franz.ak.mind.de via RT <bug-CPAN@rt.cpan.org> wrote:
Show quoted text
> 1.76_01 is now a bit old, current stable version is 1.87. Would it be > asked too much that you upgrade? Between 1.7x and 1.8x the support for > multidot version numbers was improved way big. During 1.7x support for > multidot was always buggy because version.pm was not yet written.
Actually, I set the "works_in" flag to 1.87 seven minutes after creating the ticket--the new version worked fine for me, too. Sorry; I really should have tried upgrading before reporting. Unfortunately I couldn't resolve the ticket myself. :) Thanks for looking into this! Glad to hear the upgrade-fix wasn't just coincidence. Christopher
No needs to apologize, tickets about past issues may help other people who are zapping through RT. Thanks!


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.