This queue is for tickets about the Alien-wxWidgets CPAN distribution.

Report information
The Basics
Id:
21182
Status:
rejected
Priority:
Low/Low

People
Owner:
Nobody in particular
Requestors:
rutgeraldo [...] gmail.com
Cc:
AdminCc:

BugTracker
Severity:
Normal
Broken in:
0.20
Fixed in:
0.20



Subject: Build fails on cygwin (looks fixable)
make fails on cygwin: Creating new 'Build' script for 'Alien-wxWidgets' version '0.20' /usr/bin/perl.exe Build --makefile_env_macros 1 lib/Alien/wxWidgets/Utility.pm -> blib/lib/Alien/wxWidgets/Utility.pm lib/Alien/wxWidgets.pm -> blib/lib/Alien/wxWidgets.pm Manifying blib/lib/Alien/wxWidgets/Utility.pm -> blib/libdoc/Alien.wxWidgets.Utility.3pm Manifying blib/lib/Alien/wxWidgets.pm -> blib/libdoc/Alien.wxWidgets.3pm -lwxpngd-2.6 at inc/My/Build/Any_wx_config_Bakefile.pm line 25. make: *** [all] Error 255 /usr/bin/make -- NOT OK It looks like an omission in the regex that handles the lib names, and that it should look for a different pattern. I'm using: rvosa@RUTGER ~ $ wx-config --version-full 2.6.3.1 rvosa@RUTGER ~ $ wx-config --basename wx_mswd rvosa@RUTGER ~ $ wx-config --libs -L/usr/local/lib /usr/local/lib/libwx_mswd_xrc-2.6.a /usr/local/lib/libwx_mswd_qa-2.6.a / usr/local/lib/libwx_mswd_html-2.6.a /usr/local/lib/libwx_mswd_adv-2.6.a /usr/local/lib/libw x_mswd_core-2.6.a /usr/local/lib/libwx_based_xml-2.6.a /usr/local/lib/libwx_based_net-2.6.a /usr/local/lib/libwx_based-2.6.a -ljpeg -ltiff -lexpat -lwxpngd-2.6 -lz -lrpcrt4 -loleaut3 2 -lole32 -luuid -lwinspool -lwinmm -lshell32 -lcomctl32 -lcomdlg32 -lctl3d32 -ladvapi32 -l wsock32 -lgdi32 -lkernel32 -luser32
wxPerl does not support Cygwin; it will likely never support it unless somebody provides (clean and tested) patches. Regards, Mattia


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.