Skip Menu |
 

This queue is for tickets about the Module-Install CPAN distribution.

Report information
The Basics
Id: 21061
Status: open
Priority: 0/
Queue: Module-Install

People
Owner: Nobody in particular
Requestors: kane [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: (no value)
Fixed in: 0.63



Subject: M::I spawns CPAN.pm when run under CPANPLUS for AutoInstall
Download (untitled) / with headers
text/plain 613b
Hi, I'm not sure what's going on, but i got a report from a user in this ticket about M::I: http://rt.cpan.org/Ticket/Display.html?id=20478 It turns out that during the installation of Module::Signature, which is a prereq of Bundle::CPANPLUS::Dependencies, Module::Install fires up it's autoinstall and spawns CPAN.pm to do it, even though CPANPLUS is already running. The code in Module::Install 0.63 mentions a check for PERL5_CPANPLUS_IS_RUNNING, but the code bundled with M::S (listed as M::I 0.63) doesnt have that chunk of code in it. Any thouhgts of what is going on/how to resolve this? Thanks,
Subject: Re: [rt.cpan.org #21061] M::I spawns CPAN.pm when run under CPANPLUS for AutoInstall
Date: Sat, 19 Aug 2006 12:17:04 +1000
To: bug-Module-Install [...] rt.cpan.org
From: Adam Kennedy <adam [...] phase-n.com>
Download (untitled) / with headers
text/plain 1.7k
via RT wrote: Show quoted text
> Fri Aug 18 09:17:00 2006: Request 21061 was acted upon. > Transaction: Ticket created by KANE > Queue: Module-Install > Subject: M::I spawns CPAN.pm when run under CPANPLUS for AutoInstall > Broken in: (no value) > Severity: Important > Owner: Nobody > Requestors: KANE@cpan.org > Status: new > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=21061 > > > > Hi, > > I'm not sure what's going on, but i got a report from a user in this ticket about M::I: > http://rt.cpan.org/Ticket/Display.html?id=20478 > > It turns out that during the installation of Module::Signature, which is a prereq of > Bundle::CPANPLUS::Dependencies, Module::Install fires up it's autoinstall and spawns > CPAN.pm to do it, even though CPANPLUS is already running. > > The code in Module::Install 0.63 mentions a check for PERL5_CPANPLUS_IS_RUNNING, but > the code bundled with M::S (listed as M::I 0.63) doesnt have that chunk of code in it. > > Any thouhgts of what is going on/how to resolve this?
As I think I might have mentioned before PERL5_CPANPLUS_IS_RUNNING does not actually indicate that CPANPLUS is running, only that the module has been loaded. As such it is an unreliable as an indicator which has in the past caused M:I to falsely hand off to CPANPLUS because some other piece of code had loaded CPANPLUS into memory to check a configuration value or some such. But apparently the additional checks made for CPANPLUS/CPAN.pm are not working correcting in your situation. Ideally, I'd like to see CPANPLUS changed to set a reliable environment variable that could be detected properly. Failing that, the way we are detecting CPAN.pm/CPANPLUS is otherwise not working, and probably needs to be fixed. Adam K


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.