Skip Menu |
 

This queue is for tickets about the IO-Socket-SSL CPAN distribution.

Report information
The Basics
Id: 20563
Status: rejected
Priority: 0/
Queue: IO-Socket-SSL

People
Owner: Nobody in particular
Requestors: alexchorny [...] gmail.com
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in:
  • 0.991
  • 0.97
  • 0.98
  • 0.98_1
  • 0.99
  • 0.992
  • 0.994
Fixed in: (no value)



Subject: IO::Socket::INET configuration fail
Download (untitled) / with headers
text/plain 423b
perl v5.8.7 built for MSWin32-x86-multi-thread Binary build 813 core.t fails on first test. Patched test to emit diagnostic message (TAP-compatible) with $SSL_ERROR. Error is "IO::Socket::INET configuration failederror:00000000:lib(0):func(0):reason(0)" error appears in IO::Socket::INET at defined $sock->blocking($arg->{Blocking}) or return _error($sock, $!, "$!"); ------- Alexandr Ciornii, http://chorny.net
Subject: core.t.patch
Download core.t.patch
text/x-diff 264b
*** core.t.orig Wed Jul 19 23:07:30 2006 --- core.t Wed Jul 19 23:03:36 2006 *************** *** 65,70 **** --- 65,71 ---- if (!$server) { print "not ok\n"; + print "#Error: $SSL_ERROR\n"; exit; } &ok("Server Initialization");
Download (untitled) / with headers
text/plain 731b
I have no access to a Win32 system. Can you reproduce the problem with an older version? I need to know if it was broken already in 0.97 or if it started breaking in 0.98_1 (which contained major changes). Thanks. On Mi. 19. Jul. 2006, 16:26:07, alexchorny@gmail.com wrote: Show quoted text
> perl v5.8.7 built for MSWin32-x86-multi-thread > Binary build 813 > > core.t fails on first test. Patched test to emit diagnostic message > (TAP-compatible) with $SSL_ERROR. > > Error is "IO::Socket::INET configuration > failederror:00000000:lib(0):func(0):reason(0)" > > error appears in IO::Socket::INET at > defined $sock->blocking($arg->{Blocking}) > or return _error($sock, $!, "$!"); > > ------- > Alexandr Ciornii, http://chorny.net
From: Alexandr Ciornii <alexchorny [...] gmail.com>
Download (untitled) / with headers
text/plain 435b
On Jul. 20 04:46:36 2006, SULLR wrote: Show quoted text
> I have no access to a Win32 system. > Can you reproduce the problem with an older version? > I need to know if it was broken already in 0.97 or if it started > breaking in 0.98_1 (which contained major changes).
Tried IO::Socket::SSL 0.97. core.t passes 1-st test, but hangs (or it takes very long time) after test 'Client Init from Fileno Check'. ------- Alexandr Ciornii, http://chorny.net
From: Steffen_Ullrich [...] genua.de
Download (untitled) / with headers
text/plain 728b
Thanks for your reply. It does not look like a problem, which was introduced in the latest releases, it only shows earlier now. Which version of Net::SSLeay do you use? Do all tests pass from Net::SSLeay? On Do. 20. Jul. 2006, 15:25:12, alexchorny@gmail.com wrote: Show quoted text
> On Jul. 20 04:46:36 2006, SULLR wrote:
> > I have no access to a Win32 system. > > Can you reproduce the problem with an older version? > > I need to know if it was broken already in 0.97 or if it started > > breaking in 0.98_1 (which contained major changes).
> > Tried IO::Socket::SSL 0.97. > core.t passes 1-st test, but hangs (or it takes very long time) after > test 'Client Init from Fileno Check'. > > ------- > Alexandr Ciornii, http://chorny.net
From: Alexandr Ciornii <alexchorny [...] gmail.com>
Download (untitled) / with headers
text/plain 389b
On Jul. 21 05:02:33 2006, SULLR wrote: Show quoted text
> Which version of Net::SSLeay do you use? > Do all tests pass from Net::SSLeay?
Reinstalled Net::SSLeay 1.30 with OpenSSL 0.9.7j. All tests pass. Errors in IO::Socket::SSL tests remained. It appears that problems is in IO::Socket::INET blocking method. I've wrote to Graham Barr about possible problem. ------- Alexandr Ciornii, http://chorny.net
From: Alexandr Ciornii <alexchorny [...] gmail.com>
Download (untitled) / with headers
text/plain 389b
On Jul. 21 05:02:33 2006, SULLR wrote: Show quoted text
> Which version of Net::SSLeay do you use? > Do all tests pass from Net::SSLeay?
Reinstalled Net::SSLeay 1.30 with OpenSSL 0.9.7j. All tests pass. Errors in IO::Socket::SSL tests remained. It appears that problems is in IO::Socket::INET blocking method. I've wrote to Graham Barr about possible problem. ------- Alexandr Ciornii, http://chorny.net
Download (untitled) / with headers
text/plain 438b
Did you get any feedback from Graham Barr on this problem? Do you consider it still a IO::Socket::SSL problem or can I close this bug (I cannot reproduce it because I have no access to Win32)? Steffen On Di. 01. Aug. 2006, 06:13:11, alexchorny@gmail.com wrote: Show quoted text
> > It appears that problems is in IO::Socket::INET blocking method. > I've wrote to Graham Barr about possible problem. > > ------- > Alexandr Ciornii, http://chorny.net
looks like Bug in IO::Socket::INET, not IO::Socket::SSL. Therefore Bug closed.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.