Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Module-CoreList CPAN distribution.

Report information
The Basics
Id: 20497
Status: resolved
Priority: 0/
Queue: Module-CoreList

People
Owner: RGARCIA [...] cpan.org
Requestors: altblue [...] n0i.net
Cc:
AdminCc:

Bug Information
Severity: Normal
Broken in: 2.05
Fixed in: (no value)

Attachments


Subject: fixing some perl 5.8.8 inexactities
the attached patch fixes some perl 5.8.8 modules names/versions.
Subject: Module-CoreList-2.05-5.8.8.patch
--- lib/Module/CoreList.pm.orig 2006-07-17 02:32:51.000000000 +0300 +++ lib/Module/CoreList.pm 2006-07-17 02:46:26.000000000 +0300 @@ -6696,9 +6696,10 @@ 'CPAN::FirstTime' => '1.60 ', 'CPAN::Nox' => '1.03', 'Carp' => '1.04', - 'Carp::Heavy' => '1.05', + 'Carp::Heavy' => '1.04', 'Class::ISA' => '0.33', 'Class::Struct' => '0.63', + 'Config' => undef, 'Cwd' => '3.12', 'DB' => '1.01', 'DBM_Filter' => '0.01', @@ -6746,7 +6747,7 @@ 'Env' => '1.00', 'Errno' => '1.09_01', 'Exporter' => '5.58', - 'Exporter::Heavy' => '5.59', + 'Exporter::Heavy' => '5.58', 'ExtUtils::Command' => '1.09', 'ExtUtils::Command::MM' => '0.05', 'ExtUtils::Constant' => '0.17', @@ -6780,6 +6781,7 @@ 'ExtUtils::MakeMaker::bytes'=> '0.01', 'ExtUtils::MakeMaker::vmsish'=> '0.01', 'ExtUtils::Manifest' => '1.46', + 'ExtUtils::Miniperl' => undef, 'ExtUtils::Mkbootstrap' => '1.15', 'ExtUtils::Mksymlists' => '1.19', 'ExtUtils::Packlist' => '0.04', @@ -6830,11 +6832,11 @@ 'IO::Socket' => '1.29', 'IO::Socket::INET' => '1.29', 'IO::Socket::UNIX' => '1.22', + 'IPC::Msg' => '1.02', 'IPC::Open2' => '1.02', 'IPC::Open3' => '1.02', + 'IPC::Semaphore' => '1.02', 'IPC::SysV' => '1.04', - 'IPC::SysV::Msg' => '1.02', - 'IPC::SysV::Semaphore' => '1.02', 'List::Util' => '1.18', 'Locale::Constants' => '2.07', 'Locale::Country' => '2.07', @@ -6884,10 +6886,9 @@ 'Net::netent' => '1.00', 'Net::protoent' => '1.00', 'Net::servent' => '1.01', + 'O' => '1.00', 'ODBM_File' => '1.06', 'Opcode' => '1.06', - 'Opcode::Safe' => '2.12', - 'Opcode::ops' => '1.01', 'POSIX' => '1.09', 'PerlIO' => '1.04', 'PerlIO::encoding' => '0.09', @@ -6924,6 +6925,7 @@ 'Pod::Text::Termcap' => '1.11', 'Pod::Usage' => '1.33', 'SDBM_File' => '1.05', + 'Safe' => '2.12', 'Scalar::Util' => '1.18', 'Search::Dict' => '1.02', 'SelectSaver' => '1.01', @@ -7005,6 +7007,7 @@ 'lib' => '0.5565', 'locale' => '1.00', 'open' => '1.05', + 'ops' => '1.01', 'overload' => '1.04', 're' => '0.05', 'sigtrap' => '1.02',
From: RGARCIA [...] cpan.org
Download (untitled) / with headers
text/plain 348b
On Sun Jul 16 19:53:29 2006, altblue@n0i.net wrote: Show quoted text
> the attached patch fixes some perl 5.8.8 modules names/versions.
I've fixed the script that generates information for Module::Corelist (Porting/corelist.pl in the perl source distribution) and regenerated info for several versions in 2.07, just uploaded to CPAN. Thanks for noticing this bug !


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.