This queue is for tickets about the Template-GD CPAN distribution.

Report information
The Basics
Id:
20362
Status:
new
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
alexchorny [...] gmail.com
Cc:
AdminCc:

BugTracker
Severity:
Wishlist
Broken in:
2.66
Fixed in:
(no value)



Subject: gd.t should fail when GD in not installed
Template::GD requires GD 1.14 in Makefile.PL. gd.t has legacy test skip: eval "use GD;"; if ( $@ || $GD::VERSION < 1.20 ) { skip_all('GD module(s) not installed'); } proposed patch: ok (!$@ and $GD::VERSION >= 1.20,"GD loaded"); This change also may be made in other tests. Change Makefile.PL to require GD 1.20 ------- Alexandr Ciornii, http://chorny.net


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.