Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Perl-Critic CPAN distribution.

Report information
The Basics
Id:
20213
Status:
rejected
Priority:
Low/Low
Queue:

People
Owner:
thaljef [...] cpan.org
Requestors:
adamk [...] cpan.org
Cc:
AdminCc:

BugTracker
Severity:
Normal
Broken in:
(no value)
Fixed in:
(no value)



Subject: Failed to install 0.17
Dunno exactly what's wrong here, but it failed to do something... Missing a dependency maybe? t/03_pragmas..........................Can't call abstract method 'Perl::Critic:: Policy::violates' at t/tlib/PerlCriticTestUtils.pm line 39. # Looks like your test died before it could output anything. t/03_pragmas..........................dubious Test returned status 255 (wstat 65280, 0xff00) DIED. FAILED tests 1-28 Failed 28/28 tests, 0.00% okay
Which version of Module::Pluggable do you have? -Jeff
From: adamk@cpan.org
On Sun Jul 02 23:55:54 2006, THALJEF wrote:
Show quoted text
> Which version of Module::Pluggable do you have? > > -Jeff > >
DB<2> x $Module::Pluggable::VERSION 0 2.96
I think Module::Pluggable might be incorrectly loading Perl::Critic::Policy, which is just an abstract base class. But I can't reproduce this with any of the older versions of M::P. We did have a similar problem with the latest version of M::P (v 3.01), but version 0.17 of Perl::Critic has a workaround. See also http://rt.cpan.org/Ticket/Display.html?id=19857 Can you try upgrading M::P first, and then install Perl::Critic? If that cures the problem, I'll bump up the dependency in the build script. -Jeff
CC: ADAMK@cpan.org
Subject: Re: [rt.cpan.org #20213] Failed to install 0.17
Date: Mon, 03 Jul 2006 08:43:41 -0500
To: bug-Perl-Critic@rt.cpan.org
From: Adam Kennedy <adam@phase-n.com>
Nope, didn't help. It still fails. Will analyze in more depth later. Adam K Jeffrey Thalhammer via RT wrote:
Show quoted text
> <URL: http://rt.cpan.org/Ticket/Display.html?id=20213 > > > I think Module::Pluggable might be incorrectly loading > Perl::Critic::Policy, which is just an abstract base class. But I can't > reproduce this with any of the older versions of M::P. > > We did have a similar problem with the latest version of M::P (v 3.01), > but version 0.17 of Perl::Critic has a workaround. See also > http://rt.cpan.org/Ticket/Display.html?id=19857 > > Can you try upgrading M::P first, and then install Perl::Critic? If > that cures the problem, I'll bump up the dependency in the build script. > > -Jeff
Hey Adam- Did you ever find a way around this? I've tried a few times, but I can't seem to replicate. -Jeff On Mon Jul 03 09:44:10 2006, adam@phase-n.com wrote:
Show quoted text
> Nope, didn't help. It still fails. > > Will analyze in more depth later. > > Adam K > > Jeffrey Thalhammer via RT wrote:
> > <URL: http://rt.cpan.org/Ticket/Display.html?id=20213 > > > > > I think Module::Pluggable might be incorrectly loading > > Perl::Critic::Policy, which is just an abstract base class. But I
can't
Show quoted text
> > reproduce this with any of the older versions of M::P. > > > > We did have a similar problem with the latest version of M::P (v
3.01),
Show quoted text
> > but version 0.17 of Perl::Critic has a workaround. See also > > http://rt.cpan.org/Ticket/Display.html?id=19857 > > > > Can you try upgrading M::P first, and then install Perl::Critic?
If
Show quoted text
> > that cures the problem, I'll bump up the dependency in the build
script.
Show quoted text
> > > > -Jeff
Subject: Re: [rt.cpan.org #20213] Failed to install 0.17
Date: Fri, 14 Jul 2006 16:46:25 +1000
To: bug-Perl-Critic@rt.cpan.org
From: Adam Kennedy <adam@phase-n.com>
Nope I'll have to look into this another time, I have my biggest project of the year overdue and reaching crunch point, so I'll be largely missing in action until next month. Adam K Jeffrey Thalhammer via RT wrote:
Show quoted text
> <URL: http://rt.cpan.org/Ticket/Display.html?id=20213 > > > Hey Adam- > > Did you ever find a way around this? I've tried a few times, but I > can't seem to replicate. > > -Jeff > > On Mon Jul 03 09:44:10 2006, adam@phase-n.com wrote:
>> Nope, didn't help. It still fails. >> >> Will analyze in more depth later. >> >> Adam K >> >> Jeffrey Thalhammer via RT wrote:
>>> <URL: http://rt.cpan.org/Ticket/Display.html?id=20213 > >>> >>> I think Module::Pluggable might be incorrectly loading >>> Perl::Critic::Policy, which is just an abstract base class. But I
> can't
>>> reproduce this with any of the older versions of M::P. >>> >>> We did have a similar problem with the latest version of M::P (v
> 3.01),
>>> but version 0.17 of Perl::Critic has a workaround. See also >>> http://rt.cpan.org/Ticket/Display.html?id=19857 >>> >>> Can you try upgrading M::P first, and then install Perl::Critic?
> If
>>> that cures the problem, I'll bump up the dependency in the build
> script.
>>> -Jeff
> >
I'm declaring this done. I know that Adam is using P::C v0.2 now, so I'm guessing we either solved this inadvertently or Adam fixed his Perl setup. -- Chris


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.