Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the PPI CPAN distribution.

Report information
The Basics
Id: 20031
Status: resolved
Priority: 0/
Queue: PPI

People
Owner: Nobody in particular
Requestors: carlwenrich [...] yahoo.com
Cc:
AdminCc:

Bug Information
Severity: (no value)
Broken in: (no value)
Fixed in: (no value)



Subject: PPI installation
Download (untitled) / with headers
text/plain 694b
I downloaded, gunzipped, and tar'ed the PPI (.tar.gz) file (under cygwin) and then ran perl Makefile.PL. I got the following warnings: Warning: prerequisite Clone 0.17 not found. Warning: prerequisite List::MoreUtils 0.13 not found. Warning: prerequisite List::Util 1.17 not found. We have 1.14. Warning: prerequisite Params::Util 0.10 not found. Warning: prerequisite Storable 2.14 not found. We have 2.13. Warning: prerequisite Task::Weaken 0 not found. I ran make, and everything seemed ok. When I ran make test, I got a lot more failures than successes. The stderr output said it couldn't locate any of the .pm files (which I see are in the lib/PPI directory). What am I missing? Carl
You didn't install the prerequisites that it told you were missing. NOTABUG


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.