Skip Menu |
 

This queue is for tickets about the HTML-Tree CPAN distribution.

Report information
The Basics
Id: 19796
Status: resolved
Priority: 0/
Queue: HTML-Tree

People
Owner: Nobody in particular
Requestors: rjbs [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: (no value)
Fixed in: (no value)



Subject: HTML::Parser prereq seems incorrect
Download (untitled) / with headers
text/plain 533b
When installing HTML-Tree, I got test failures. (Now lost to my scrollback.) It was in checking that ' was turned into an entity for a link regarding TheDamian in a dress. My assumption was that HMTL::Entities needed updating, and this did indeed make the tests pass. There is no HTML::Entity prereq, but HTML::Parser is a prereq, which is in the same dist. We were running HTML-Parser 3.35 and updated to latest, 3.54. I believe the correct minimum to be 3.46: HTML::Entities::encode will now encode "'" by default.
Download (untitled) / with headers
text/plain 102b
Patch applied to svn requiring HTML::Parser 3.46, which will be part of the next release of HTML-Tree.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.