Skip Menu |
 

This queue is for tickets about the SOAP-Lite CPAN distribution.

Report information
The Basics
Id: 19697
Status: new
Priority: 0/
Queue: SOAP-Lite

People
Owner: Nobody in particular
Requestors: fs [...] ecce-terram.de
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: 0.67
Fixed in: (no value)



Subject: Problems sending/receiving SOAP Messaging
Download (untitled) / with headers
text/plain 2.3k
Hi, we have a SOAP-Server and SOAP-Client using SOAP::Lite 0.60 on FreeBSD 5.4 with Perl5.8.8. Yesterday i update to 0.67 and my SOAP Testprogramm now get an error: SOAP-FAULT: Application failed during request deserialization: XML or text declaration not at start of entity at line 1, column 504, byte 504 at /usr/local/ lib/perl5/site_perl/5.8.8/mach/XML/Parser.pm line 187 at ../livetest.pl line 57 ECCE::PTS::LIVETEST::handleError('ECCE::PTS::LIVETEST=HASH(0x8979370)', 'SOAP::SOM=HASH(0x8c1e874)') called at ../livetest.pl line 170 ECCE::PTS::LIVETEST::_default('ECCE::PTS::LIVETEST=HASH(0x8979370)') called at /usr/ local/lib/perl5/site_perl/5.8.8/ECCE/AbstractApplication.pm line 264 eval {...} called at /usr/local/lib/perl5/site_perl/5.8.8/ECCE/AbstractApplication.pm line 263 ECCE::AbstractApplication::run('ECCE::PTS::LIVETEST=HASH(0x8979370)') called at ../ livetest.pl line 29 We send an correct XML-File (validaded with xmllint). If i send the XML File via an SOAP Call from another Client using 0.60 it works. The XML-File starts with: <?xml version="1.0" encoding="UTF-8"?> <tron_order_xml xmlns="http://pts.ecce-terram.de/tron_order_xml" xmlns:xsi="http:// www.w3.org/2001/XMLSchema-insta nce" xsi:schemaLocation="http://pts.ecce-terram.de/tron_order_xml C:\develop\ephoto\src \tron\tron_order_xml.xsd"> <protocol_version> <ID>02010200</ID> <name>$Id: order.xml,v 1.1 2006/05/15 12:03:09 etteam Exp $</name> </protocol_version> <received> ... and we receveid: <?xml version="1.0" encoding="UTF-8"?><soap:Envelope xmlns:xsi="http://www.w3.org/ 2001/XMLSchema-instance" xmlns:S OAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" xmlns:tron="http://pts.ecce- terram.de/TRONServer" xmlns:xsd="h ttp://www.w3.org/2001/XMLSchema" soap:encodingStyle="http://schemas.xmlsoap.org/ soap/encoding/" xmlns:soap="http:/ /schemas.xmlsoap.org/soap/ envelope/"><soap:Body><soap:Fault><faultcode>soap:Client</ Show quoted text
faultcode><faultstring>Applica
tion failed during request deserialization: XML or text declaration not at start of entity at line 1, column 504, byte 504 at /usr/local/ lib/perl5/site_perl/5 .8.8/mach/XML/Parser.pm line 192 </faultstring></soap:Fault></soap:Body></soap:Envelope> I know, that are not many information, but i hope the problem is well known and can find. The problem only appears, if SOAP::Lite 0.67 is using on the Client-site. best regards Frank


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.