Skip Menu |
 

This queue is for tickets about the Math-Pari CPAN distribution.

Report information
The Basics
Id: 19621
Status: open
Priority: 0/
Queue: Math-Pari

People
Owner: Nobody in particular
Requestors: jjperry [...] water.com
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 2.010705
Fixed in: (no value)



Subject: Failure to compile with automatically downloaded Pari version 2.3.0
Download (untitled) / with headers
text/plain 623b
When doing both CPAN and manual installations of the Math::Pari module it failed with the error "Make: Don't know how to make ../../../pari-2.3.0/src/kernel/none/level0.h. Stop." From reading the README file I see that 2.010705 was last tested with version 2.1.7 of Pari but the automatic CPAN and Perl scripts download Pari-2.3.0 from ftp://megrez.math.u-bordeaux.fr/pub/pari. Downloading of Pari-2.1.7 resolved the compilation issue but all versions tested via a CPAN install failed on multiple hosts OS. I tested HP-UX 11.0, 11.11, RedHat Linux EL4 WS, and Fedora Core. Pari-2.3.0 was updated on May 15, 2006.
CC: undisclosed-recipients: ;
Subject: Re: [rt.cpan.org #19621] Failure to compile with automatically downloaded Pari version 2.3.0
Date: Wed, 31 May 2006 14:02:59 -0700
To: Guest via RT <bug-Math-Pari [...] rt.cpan.org>
From: Ilya Zakharevich <nospam-abuse [...] ilyaz.org>
Download (untitled) / with headers
text/plain 1.1k
On Wed, May 31, 2006 at 01:55:00PM -0400, Guest via RT wrote: Show quoted text
> > Wed May 31 13:54:59 2006: Request 19621 was acted upon. > Transaction: Ticket created by guest > Queue: Math-Pari > Subject: Failure to compile with automatically downloaded Pari version 2.3.0 > Broken in: 2.010705 > Severity: Critical > Owner: Nobody > Requestors: jjperry@water.com > Status: new > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=19621 > > > > When doing both CPAN and manual installations of the Math::Pari module > it failed with the error "Make: Don't know how to make > ../../../pari-2.3.0/src/kernel/none/level0.h. Stop." From reading the > README file I see that 2.010705 was last tested with version 2.1.7 of > Pari but the automatic CPAN and Perl scripts download Pari-2.3.0 from > ftp://megrez.math.u-bordeaux.fr/pub/pari. > > Downloading of Pari-2.1.7 resolved the compilation issue but all > versions tested via a CPAN install failed on multiple hosts OS. I > tested HP-UX 11.0, 11.11, RedHat Linux EL4 WS, and Fedora Core. > > Pari-2.3.0 was updated on May 15, 2006.
Math::Pari was updated on May 30. Hope this helps, Ilya
Subject: RE: [rt.cpan.org #19621] Failure to compile with automatically downloaded Pari version 2.3.0
Date: Wed, 31 May 2006 17:43:09 -0400
To: <bug-Math-Pari [...] rt.cpan.org>
From: "James J. Perry" <jjperry [...] water.com>
Download (untitled) / with headers
text/plain 1.5k
Guess it has not yet made it to the CPAN mirror as the version I got today was 2.010705 and it failed. Show quoted text
-----Original Message----- From: Ilya Zakharevich via RT [mailto:bug-Math-Pari@rt.cpan.org] Sent: Wednesday, May 31, 2006 5:05 PM To: James J. Perry Subject: Re: [rt.cpan.org #19621] Failure to compile with automatically downloaded Pari version 2.3.0 <URL: http://rt.cpan.org/Ticket/Display.html?id=19621 > On Wed, May 31, 2006 at 01:55:00PM -0400, Guest via RT wrote:
> > Wed May 31 13:54:59 2006: Request 19621 was acted upon. > Transaction: Ticket created by guest > Queue: Math-Pari > Subject: Failure to compile with automatically downloaded Pari
version 2.3.0
> Broken in: 2.010705 > Severity: Critical > Owner: Nobody > Requestors: jjperry@water.com > Status: new > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=19621 > > > > When doing both CPAN and manual installations of the Math::Pari module > it failed with the error "Make: Don't know how to make > ../../../pari-2.3.0/src/kernel/none/level0.h. Stop." From reading
the
> README file I see that 2.010705 was last tested with version 2.1.7 of > Pari but the automatic CPAN and Perl scripts download Pari-2.3.0 from > ftp://megrez.math.u-bordeaux.fr/pub/pari. > > Downloading of Pari-2.1.7 resolved the compilation issue but all > versions tested via a CPAN install failed on multiple hosts OS. I > tested HP-UX 11.0, 11.11, RedHat Linux EL4 WS, and Fedora Core. > > Pari-2.3.0 was updated on May 15, 2006.
Math::Pari was updated on May 30. Hope this helps, Ilya
From: Mikko Rantanen
Download (untitled) / with headers
text/plain 5.3k
Hello all, (sorry for top-posting, it seems to be prevalent here..) For the record, I'm doing this under cygwin. My gcc --version is cc (GCC) 3.4.4 (cygming special) (gdc 0.12, using dmd 0.125). I'm having problems as well. Did perl -MCPAN -e shell and install Math::Pari. The libpari.a build was successful but the Pari.xs in the downloaded .tar.gz is faulty. I'll include last few lines from the process: gcc -c -I ../../../../pari-2.3.0/src -I../../../../pari- 2.3.0/src/headers -I../../../../pari-2.3.0/src/graph -I. - DPERL_USE_SAFE_PU TENV -fno-strict-aliasing -pipe -I/usr/local/include -DUSEIMPORTLIB - O3 -DVERSION=\"\" -DXS_VERSION=\"\" -Derr=pari_err -DASMINLI NE -DGCC_INLINE -DDYNAMIC_PLOTTING -o mpinl.o ../../../../pari- 2.3.0/src/kernel/none/mpinl.c rm -f libPARI.a ar cr libPARI.a es.o base5.o Flx.o bibli1.o buch2.o init.o gen1.o galconj.o trans3.o intnum.o RgX.o buch4.o sumiter.o polarit2.o ge n3.o Qfb.o alglin2.o stark.o errmsg.o default.o arith1.o buch1.o nffactor.o galois.o subfield.o perm.o gen2.o highlvl.o arith2.o pol arit1.o subcyclo.o subgroup.o elldata.o alglin1.o base2.o polarit3.o ifactor1.o groupid.o plotport.o base1.o bibli2.o trans2.o trans 1.o kummer.o buch3.o part.o plotnull.o elliptic.o mpqs.o thue.o members.o base4.o aprcl.o anal.o rootpol.o compat.o base3.o mp.o mpi nl.o : libPARI.a make[1]: Leaving directory `/home/dogo/.cpan/build/Math-Pari- 2.010706/libPARI' make[1]: Entering directory `/home/dogo/.cpan/build/Math-Pari- 2.010706/libPARI' make[1]: Nothing to be done for `all'. make[1]: Leaving directory `/home/dogo/.cpan/build/Math-Pari- 2.010706/libPARI' /usr/bin/perl.exe /usr/lib/perl5/5.8/ExtUtils/xsubpp - typemap /usr/lib/perl5/5.8/ExtUtils/typemap -typemap typemap Pari.xs Show quoted text
> Pari.xsc && mv Pari.xsc Pari.c
gcc -c -I ../../../pari-2.3.0/src -I../../../pari-2.3.0/src/headers - I../../../pari-2.3.0/src -I./libPARI -DPERL_USE_SAFE_PUTENV -f no-strict-aliasing -pipe -I/usr/local/include -DUSEIMPORTLIB -O3 - DVERSION=\"2.010706\" -DXS_VERSION=\"2.010706\" "-I/usr/lib/per l5/5.8/cygwin/CORE" -DPARI_VERSION_EXP=2003000 -DDEBUG_PARI - DLSB_in_U32=0 -DLONG_SHORTER_THAN_IV -Derr=pari_err -DGCC_INLINE -DHAV E_PARIPRIV -DNO_GRAPHICS_PARI Pari.c Pari.xs: In function `findVariable': Pari.xs:422: warning: cast to pointer from integer of different size Pari.xs:438: warning: cast to pointer from integer of different size Pari.xs:661:4: #error "LONG_SHORTER_THAN_IV not implemented" Pari.xs: In function `my_UVtoi': Pari.xs:667: error: parse error before ';' token Pari.xs: In function `sv2pari': Pari.xs:707: warning: cast to pointer from integer of different size Pari.xs:713: warning: cast to pointer from integer of different size Pari.xs: In function `resetSVpari': Pari.xs:1093: warning: cast from pointer to integer of different size Pari.xs: In function `moveoffstack_newer_than': Pari.xs:1189: warning: cast to pointer from integer of different size Pari.xs:1189: warning: cast from pointer to integer of different size Pari.xs: In function `XS_Math__Pari_DESTROY': Pari.xs:3770: warning: cast to pointer from integer of different size make: *** [Pari.o] Error 1 /usr/bin/make -- NOT OK Running make test Can't test without successful make Running make install make had returned bad status, install seems impossible Failed during this command: ILYAZ/modules/Math-Pari-2.010706.tar.gz : make NO I downloaded from http://search.cpan.org/CPAN/authors/id/I/IL/ILYAZ/modules/Math-Pari- 2.010706.tar.gz and checked that the Pari.xs file has different number of opening/closing parenthesises. Anyone can fix the line 667, but tracing the GEN definition leads to file 'typemap' and typemap shows 'GEN T_Pari' and either $var = sv2pari($arg) or setSVpari ($arg, $var, oldavma);. I have no clue what the casts should actually be, so my road ends there. Show quoted text
> -----Original Message----- > From: Ilya Zakharevich via RT [mailto:bug-Math-Pari@rt.cpan.org] > Sent: Wednesday, May 31, 2006 5:05 PM > To: James J. Perry > Subject: Re: [rt.cpan.org #19621] Failure to compile with
automatically Show quoted text
> downloaded Pari version 2.3.0 > > > <URL: http://rt.cpan.org/Ticket/Display.html?id=19621 > > > On Wed, May 31, 2006 at 01:55:00PM -0400, Guest via RT wrote:
> > > > Wed May 31 13:54:59 2006: Request 19621 was acted upon. > > Transaction: Ticket created by guest > > Queue: Math-Pari > > Subject: Failure to compile with automatically downloaded Pari
> version 2.3.0
> > Broken in: 2.010705 > > Severity: Critical > > Owner: Nobody > > Requestors: jjperry@water.com > > Status: new > > Ticket <URL: http://rt.cpan.org/Ticket/Display.html?id=19621 > > > > > > > When doing both CPAN and manual installations of the Math::Pari
module Show quoted text
> > it failed with the error "Make: Don't know how to make > > ../../../pari-2.3.0/src/kernel/none/level0.h. Stop." From reading
> the
> > README file I see that 2.010705 was last tested with version 2.1.7
of Show quoted text
> > Pari but the automatic CPAN and Perl scripts download Pari-2.3.0
from Show quoted text
> > ftp://megrez.math.u-bordeaux.fr/pub/pari. > > > > Downloading of Pari-2.1.7 resolved the compilation issue but all > > versions tested via a CPAN install failed on multiple hosts OS. I > > tested HP-UX 11.0, 11.11, RedHat Linux EL4 WS, and Fedora Core. > > > > Pari-2.3.0 was updated on May 15, 2006.
> > Math::Pari was updated on May 30. > > Hope this helps, > Ilya > >
Best regards, -- Mikko Rantanen
CC: undisclosed-recipients: ;
Subject: Re: [rt.cpan.org #19621] Failure to compile with automatically downloaded Pari version 2.3.0
Date: Tue, 6 Jun 2006 08:34:04 -0700
To: Guest via RT <bug-Math-Pari [...] rt.cpan.org>
From: Ilya Zakharevich <nospam-abuse [...] ilyaz.org>
Download (untitled) / with headers
text/plain 707b
On Tue, Jun 06, 2006 at 08:37:38AM -0400, Guest via RT wrote: Show quoted text
> For the record, I'm doing this under cygwin. My gcc --version is cc > (GCC) 3.4.4 (cygming special) (gdc 0.12, using dmd 0.125).
The procedure to report bugs is documented in README and/or INSTALL. Show quoted text
> Pari.xs:661:4: #error "LONG_SHORTER_THAN_IV not implemented"
Aha, one finally can try to test this code... Could you remove this line? Show quoted text
> Pari.xs: In function `my_UVtoi': > Pari.xs:667: error: parse error before ';' token
One closing parens is missing. Could you add it? Please test. [Do not know why you are testing with 2.3.0, it should be skipped unless forced manually... This build should not be supported yet...] Thanks, Ilya
Download (untitled) / with headers
text/plain 962b
On Втр. Июн. 06 11:35:47 2006, nospam-abuse@ilyaz.org wrote: Show quoted text
> On Tue, Jun 06, 2006 at 08:37:38AM -0400, Guest via RT wrote:
> > For the record, I'm doing this under cygwin. My gcc --version is cc > > (GCC) 3.4.4 (cygming special) (gdc 0.12, using dmd 0.125).
> > The procedure to report bugs is documented in README and/or INSTALL. >
> > Pari.xs:661:4: #error "LONG_SHORTER_THAN_IV not implemented"
> > Aha, one finally can try to test this code... Could you remove this
line? Show quoted text
>
> > Pari.xs: In function `my_UVtoi': > > Pari.xs:667: error: parse error before ';' token
> > One closing parens is missing. Could you add it?
No sure that is was parens =). It must be line 667: GEN b = my_ulongtoi((ulong)(uv & ((((UV)1)<<(8*sizeof(ulong))) - 1)); MUST BE: GEN b = my_ulongtoi((ulong)(uv & ((((UV)1)<<(8*sizeof(ulong))) - 1))); and of course remove or comment line Pari.xs:661:4: #error "LONG_SHORTER_THAN_IV not implemented" WBR Alexey Polyakov
CC: undisclosed-recipients: ;
Subject: Re: [rt.cpan.org #19621] Failure to compile with automatically downloaded Pari version 2.3.0
Date: Sun, 11 Jun 2006 00:24:13 -0700
To: Guest via RT <bug-Math-Pari [...] rt.cpan.org>
From: Ilya Zakharevich <nospam-abuse [...] ilyaz.org>
Download (untitled) / with headers
text/plain 795b
On Sat, Jun 10, 2006 at 12:52:03PM -0400, Guest via RT wrote: Show quoted text
> > > Pari.xs:661:4: #error "LONG_SHORTER_THAN_IV not implemented"
> > > > Aha, one finally can try to test this code... Could you remove this
> line?
> >
> > > Pari.xs: In function `my_UVtoi': > > > Pari.xs:667: error: parse error before ';' token
> > > > One closing parens is missing. Could you add it?
> > No sure that is was parens =). It must be > line 667: > GEN b = my_ulongtoi((ulong)(uv & ((((UV)1)<<(8*sizeof(ulong))) - 1)); > MUST BE: > GEN b = my_ulongtoi((ulong)(uv & ((((UV)1)<<(8*sizeof(ulong))) - 1))); > > and of course remove or comment line > Pari.xs:661:4: #error "LONG_SHORTER_THAN_IV not implemented"
But I do not understand the EFFECTS. After correcting this, do build/tests succeed? Thanks, Ilya
From: Alexey Polyakov
Download (untitled) / with headers
text/plain 963b
On Вск. Июн. 11 03:24:54 2006, nospam-abuse@ilyaz.org wrote: Show quoted text
> On Sat, Jun 10, 2006 at 12:52:03PM -0400, Guest via RT wrote:
> > > > Pari.xs:661:4: #error "LONG_SHORTER_THAN_IV not implemented"
> > > > > > Aha, one finally can try to test this code... Could you remove
this Show quoted text
> > line?
> > >
> > > > Pari.xs: In function `my_UVtoi': > > > > Pari.xs:667: error: parse error before ';' token
> > > > > > One closing parens is missing. Could you add it?
> > > > No sure that is was parens =). It must be > > line 667: > > GEN b = my_ulongtoi((ulong)(uv & ((((UV)1)<<(8*sizeof(ulong))) - 1)
); Show quoted text
> > MUST BE: > > GEN b = my_ulongtoi((ulong)(uv & ((((UV)1)<<(8*sizeof(ulong))) - 1)
)); Show quoted text
> > > > and of course remove or comment line > > Pari.xs:661:4: #error "LONG_SHORTER_THAN_IV not implemented"
> > But I do not understand the EFFECTS. After correcting this, do > build/tests succeed? > > Thanks, > Ilya
Of cource success! And for now all work fine.
CC: undisclosed-recipients: ;
Subject: Re: [rt.cpan.org #19621] Failure to compile with automatically downloaded Pari version 2.3.0
Date: Sat, 17 Jun 2006 05:56:58 -0700
To: Guest via RT <bug-Math-Pari [...] rt.cpan.org>
From: Ilya Zakharevich <nospam-abuse [...] ilyaz.org>
Download (untitled) / with headers
text/plain 441b
On Sat, Jun 17, 2006 at 05:08:53AM -0400, Guest via RT wrote: Show quoted text
> > > and of course remove or comment line > > > Pari.xs:661:4: #error "LONG_SHORTER_THAN_IV not implemented"
> > > > But I do not understand the EFFECTS. After correcting this, do > > build/tests succeed?
Show quoted text
> Of cource success! And for now all work fine.
Thanks! (But, of course, there is no "of course success" after you reach some level of complexity... ;-() Yours, Ilya
From: gslin [...] gslin.org
Download (untitled) / with headers
text/plain 863b
On 2006-06-17 08:58:05 星期六, nospam-abuse@ilyaz.org wrote: Show quoted text
> On Sat, Jun 17, 2006 at 05:08:53AM -0400, Guest via RT wrote:
> > > > and of course remove or comment line > > > > Pari.xs:661:4: #error "LONG_SHORTER_THAN_IV not implemented"
> > > > > > But I do not understand the EFFECTS. After correcting this, do > > > build/tests succeed?
>
> > Of cource success! And for now all work fine.
> > Thanks! (But, of course, there is no "of course success" after you > reach some level of complexity... ;-() > > Yours, > Ilya
On FreeBSD 6.1-RELEASE (with Perl-5.8.8), ivsize=8, longsize=4, so LONG_SHORTER_THAN_IV have been set. This patch will fix the build but cause coredump: gslin@netnews [~] [21:11/W5] cat t.pl #!/usr/bin/perl use Math::Pari; gslin@netnews [~] [21:11/W5] perl t.pl Segmentation fault (core dumped) What information can I offer ?


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.