Skip Menu |
 

Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Devel-Cover CPAN distribution.

Report information
The Basics
Id: 19572
Status: resolved
Priority: 0/
Queue: Devel-Cover

People
Owner: Nobody in particular
Requestors: rafl [...] debian.org
Cc:
AdminCc:

Bug Information
Severity: Unimportant
Broken in: 0.55
Fixed in: (no value)



Download (untitled) / with headers
text/plain 731b
Hello, I'm the Debian maintainer of the Devel::Cover module and recieved a bug report from one of its users: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=362015 He basically complains about the permissions used for the cover_db. As it seems, the currently used permissions where introduced to work around bug in perl 5.6.x. I wonder if those problems have been fixed in perl and if it would be possible the use sane permissions with recent perl versions? If yes, I'd like to propose that Devel::Cover should check for a minimum version of perl, which has been verified to work, and use proper permissions. Otherwise, when the given minimum version number is not met, it should fall back to its current behaviour. TIA, Flo
Subject: Re: [rt.cpan.org #19572]
Date: Sat, 30 Dec 2006 14:14:55 +0100
To: Florian Ragwitz via RT <bug-Devel-Cover [...] rt.cpan.org>
From: Paul Johnson <paul [...] pjcj.net>
Download (untitled) / with headers
text/plain 370b
On Mon, May 29, 2006 at 08:23:52AM -0400, Florian Ragwitz via RT wrote: Show quoted text
Fixed with http://pjcj.sytes.net/svnweb/Devel::Cover/revision/?rev=114, as you noticed. Thanks very much for dealing with the report, and thanks for looking after the debian package. -- Paul Johnson - paul@pjcj.net http://www.pjcj.net


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.