Skip Menu |
 

This queue is for tickets about the CGI-Session CPAN distribution.

Report information
The Basics
Id: 19368
Status: resolved
Priority: 0/
Queue: CGI-Session

People
Owner: Nobody in particular
Requestors: adam [...] jamradar.com
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: 4.13
Fixed in: (no value)



Subject: CGI::Session from 3.95 to 4.11 breaks CGI::Session::PostgreSQL
Download (untitled) / with headers
text/plain 577b
I upgraded CGI::Session from 3.95 to 4.11 and now I'm getting this error when using CGI::Session::PostgreSQL Software error: Can't call method "isa" on an undefined value at /usr/lib/perl5/site_p +erl/5.8.8/CGI/Session/Auth.pm line 52. Why is CGI::Session erroring out now? Is this a bug? This also errors out from the command line. Here are the versions that I'm using: CGI::Session - 4.11 CGI::Session::Auth - 1.021 CGI::Session::Auth::DBI - 1.012 CGI::Session::PostgreSQL - 1.2 Perl 5.8.8 Here is a link to the error discripton: http://www.perlmonks.com/?node_id=550451
Subject: Re: [rt.cpan.org #19368] CGI::Session from 3.95 to 4.11 breaks CGI::Session::PostgreSQL
Date: Mon, 22 May 2006 10:07:01 -0400
To: Guest via RT <bug-CGI-Session [...] rt.cpan.org>
From: Mark Stosberg <mark [...] summersault.com>
Download (untitled) / with headers
text/plain 825b
On Sat, May 20, 2006 at 12:04:06AM -0400, Guest via RT wrote: Show quoted text
> > > I upgraded CGI::Session from 3.95 to 4.11 and now I'm getting this error > when using CGI::Session::PostgreSQL > > Software error: Can't call method "isa" on an undefined value at > /usr/lib/perl5/site_p +erl/5.8.8/CGI/Session/Auth.pm line 52. > > > Why is CGI::Session erroring out now? Is this a bug? This also errors > out from the command line. Here are the versions that I'm using: > CGI::Session - 4.11 > CGI::Session::Auth - 1.021 > CGI::Session::Auth::DBI - 1.012 > CGI::Session::PostgreSQL - 1.2 > Perl 5.8.8 > > Here is a link to the error discripton: > http://www.perlmonks.com/?node_id=550451
This is not a bug, but a documented change in the driver format. A new, working, PostgreSQL driver is distributed with CGI::Session 4.x. Mark


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.