Preferred bug tracker

Please visit the preferred bug tracker to report your issue.

This queue is for tickets about the Perl-Critic CPAN distribution.

Report information
The Basics
Id:
19153
Status:
rejected
Priority:
Low/Low
Queue:

People
Owner:
Nobody in particular
Requestors:
steve.kirkup [...] dss.virginia.gov
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
0.15
Fixed in:
0.15



Subject: Windows Incompatibilities...
This is not so much a bug but an incompability with different version of ActivePerl. PPI requires Scalar::Util 1.18 but it needs to be compiled with .xs. If you use cpan, it will install Scalar::Util without .xs which kinda breaks Scalar::Util and then you cannot install PPI. Also because Scalar::Util is part of the standard distribution the only why to get it reinstalled with .xs is to reinstall the whole Activestate distribution. This is fixed in Activestate distribution 5.8.8 Build 817. Suggestion, can you include a check to see if you are on a Windows box to see if you are at least at 5.8.8 before doing the installation? It took me a while to figure out that using cpan without a c compiler is very painful! :)
From: cdolan@cpan.org
On Mon May 08 14:39:36 2006, guest wrote:
Show quoted text
> This is not so much a bug but an incompability with different version of > ActivePerl. > > PPI requires Scalar::Util 1.18 but it needs to be compiled with .xs. If > you use cpan, it will install Scalar::Util without .xs which kinda > breaks Scalar::Util and then you cannot install PPI. Also because > Scalar::Util is part of the standard distribution the only why to get it > reinstalled with .xs is to reinstall the whole Activestate distribution. > > This is fixed in Activestate distribution 5.8.8 Build 817. > > Suggestion, can you include a check to see if you are on a Windows box > to see if you are at least at 5.8.8 before doing the installation? It > took me a while to figure out that using cpan without a c compiler is > very painful! :)
Steve, Thanks for the report but I think this is way beyond the scope of Perl::Critic to address. If anything, it sounds like Scalar::Util should have a warning/recommendation rather than Perl::Critic since we are two levels downstream. Perhaps you could add a note to annocpan.org for Scalar::Util? Chris
Subject: RE: [rt.cpan.org #19153] Windows Incompatibilities...
Date: Tue, 9 May 2006 10:02:14 -0400
To: <bug-Perl-Critic@rt.cpan.org>
From: "Steve Kirkup" <steve.kirkup@dss.virginia.gov>
Chris, The fundamental problem really is that cpan will always attempt to install a more current module with or without .XS installed over-top of the current module. You are right that Perl::Critic is pretty far downstream but I figured I could mention it to you and it could be mentioned in the documentation or the installer. Let me submit this as a bug to the cpan utility which is where the problem really lies. Steve Kirkup
Show quoted text
-----Original Message----- From: via RT [mailto:bug-Perl-Critic@rt.cpan.org] Sent: Tuesday, May 09, 2006 9:57 AM To: steve.kirkup@dss.virginia.gov Subject: [rt.cpan.org #19153] Windows Incompatibilities... <URL: http://rt.cpan.org/Ticket/Display.html?id=19153 > On Mon May 08 14:39:36 2006, guest wrote:
> This is not so much a bug but an incompability with different version of > ActivePerl. > > PPI requires Scalar::Util 1.18 but it needs to be compiled with .xs. If > you use cpan, it will install Scalar::Util without .xs which kinda > breaks Scalar::Util and then you cannot install PPI. Also because > Scalar::Util is part of the standard distribution the only why to get it > reinstalled with .xs is to reinstall the whole Activestate distribution. > > This is fixed in Activestate distribution 5.8.8 Build 817. > > Suggestion, can you include a check to see if you are on a Windows box > to see if you are at least at 5.8.8 before doing the installation? It > took me a while to figure out that using cpan without a c compiler is > very painful! :)
Steve, Thanks for the report but I think this is way beyond the scope of Perl::Critic to address. If anything, it sounds like Scalar::Util should have a warning/recommendation rather than Perl::Critic since we are two levels downstream. Perhaps you could add a note to annocpan.org for Scalar::Util? Chris


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.