Skip Menu |
 

This queue is for tickets about the XML-LibXML CPAN distribution.

Report information
The Basics
Id: 18506
Status: rejected
Priority: 0/
Queue: XML-LibXML

People
Owner: Nobody in particular
Requestors: Beyerj [...] student.uni-marburg.de
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: (no value)
Fixed in: (no value)

Attachments
XML-LibXML-1.58_w_gcc401.txt



Subject: Bugs: XML::LibXML v1.58 or v1.58_1 do not build under Mac OS X 10.4 w/ default compiler
Download (untitled) / with headers
text/plain 1.5k
Specs: PowerMac G4/400 PCI (Oct. 1999) Mac OS X 10.4.5 (latest) w/ libxml2 v2.6.16 Apple DevTools 2.2.1 (latest) compiler gcc 4.0.1 and gcc 3.3 Perl 5.8.6 (factory/preinstalled) The default compiler in Mac OS X 10.4.x is gcc 4.0.1. Trying to install XML::LibXML v1.58 or v1.58_1 with gcc 4.0.1 leads to three problems: (1) Warning while running 'perl makefile.PL' "running xml2-config...untested WARNING! The installed version of libxml2 was not tested with this version of XML::LibXML. XML::LibXML may fail building or some tests may not pass. Expect strange errors and unstable scripts. Check the README file for more informations END OF WARNING " Well, the Readme does not say something helpfull... It's out of date. (2) "Signedness warnings" during 'make' With gcc 4.0.1 you get a bunch of "signedness warnings" during the 'make'-Phase (see attached log). (3) Warning of deprecated DOCBparser At last, there is the following warning: /usr/include/libxml2/libxml/DOCBparser.h:22:2: warning: #warning "The DOCBparser module has been deprecated in libxml2-2.6.0" Just for the record -- this problem is not only Apple/OS X related, there are some general problems with XML::LibXML and related modules in their current states. Perl modules are expected to be platform independent, and these ones aren't. I contacted the author of XML::LibXML and related modules, Christian Glahn, a week ago and still hope to get an answer. But since this bug list grows, while there is no visible development or maintenance of XML::LibXML since two years, I think we're all out of luck. Cheers Joerg
Subject: XML-LibXML-1.58_w_gcc401.txt
Last login: Sat Mar 25 01:56:22 on ttyp1 Welcome to Darwin! Nachtblauer-Tower:~ beyerjoerg$ gcc_select Current default compiler: gcc version 4.0.1 (Apple Computer, Inc. build 5250) Nachtblauer-Tower:~ beyerjoerg$ cd /Volumes/PerlStuff/XML-LibXML-1.58/ Nachtblauer-Tower:/Volumes/PerlStuff/XML-LibXML-1.58 beyerjoerg$ ls Changes README perl-libxml-sax.c LICENSE dom.c perl-libxml-sax.h LibXML.pm dom.h ppport.h LibXML.pod example t LibXML.xs lib typemap MANIFEST perl-libxml-mm.c xpath.c Makefile.PL perl-libxml-mm.h xpath.h Nachtblauer-Tower:/Volumes/PerlStuff/XML-LibXML-1.58 beyerjoerg$ perl Makefile.PL enable native perl UTF8 running xml2-config...untested WARNING! The installed version of libxml2 was not tested with this version of XML::LibXML. XML::LibXML may fail building or some tests may not pass. Expect strange errors and unstable scripts. Check the README file for more informations END OF WARNING looking for -lxml2... yes Checking if your kit is complete... Looks good Writing Makefile for XML::LibXML Nachtblauer-Tower:/Volumes/PerlStuff/XML-LibXML-1.58 beyerjoerg$ make cp lib/XML/LibXML/DOM.pod blib/lib/XML/LibXML/DOM.pod cp lib/XML/LibXML/Number.pm blib/lib/XML/LibXML/Number.pm cp lib/XML/LibXML/SAX.pm blib/lib/XML/LibXML/SAX.pm cp lib/XML/LibXML/Literal.pm blib/lib/XML/LibXML/Literal.pm cp lib/XML/LibXML/Node.pod blib/lib/XML/LibXML/Node.pod cp lib/XML/LibXML/SAX/Builder.pm blib/lib/XML/LibXML/SAX/Builder.pm cp LibXML.pm blib/lib/XML/LibXML.pm cp lib/XML/LibXML/Parser.pod blib/lib/XML/LibXML/Parser.pod cp lib/XML/LibXML/DocumentFragment.pod blib/lib/XML/LibXML/DocumentFragment.pod cp lib/XML/LibXML/Element.pod blib/lib/XML/LibXML/Element.pod cp lib/XML/LibXML/SAX/Parser.pm blib/lib/XML/LibXML/SAX/Parser.pm cp lib/XML/LibXML/Namespace.pod blib/lib/XML/LibXML/Namespace.pod cp lib/XML/LibXML/SAX/Builder.pod blib/lib/XML/LibXML/SAX/Builder.pod cp lib/XML/LibXML/Document.pod blib/lib/XML/LibXML/Document.pod cp lib/XML/LibXML/Attr.pod blib/lib/XML/LibXML/Attr.pod cp lib/XML/LibXML/SAX/Generator.pm blib/lib/XML/LibXML/SAX/Generator.pm cp lib/XML/LibXML/CDATASection.pod blib/lib/XML/LibXML/CDATASection.pod cp LibXML.pod blib/lib/XML/LibXML.pod cp lib/XML/LibXML/SAX.pod blib/lib/XML/LibXML/SAX.pod cp lib/XML/LibXML/Text.pod blib/lib/XML/LibXML/Text.pod cp lib/XML/LibXML/Boolean.pm blib/lib/XML/LibXML/Boolean.pm cp lib/XML/LibXML/PI.pod blib/lib/XML/LibXML/PI.pod cp lib/XML/LibXML/NodeList.pm blib/lib/XML/LibXML/NodeList.pm cp lib/XML/LibXML/Comment.pod blib/lib/XML/LibXML/Comment.pod cp lib/XML/LibXML/Dtd.pod blib/lib/XML/LibXML/Dtd.pod /usr/bin/perl /System/Library/Perl/5.8.6/ExtUtils/xsubpp -typemap /System/Library/Perl/5.8.6/ExtUtils/typemap -typemap typemap LibXML.xs > LibXML.xsc && mv LibXML.xsc LibXML.c cc -c -I/usr/include/libxml2 -g -pipe -fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -I/usr/local/include -Os -DVERSION=\"1.58\" -DXS_VERSION=\"1.58\" "-I/System/Library/Perl/5.8.6/darwin-thread-multi-2level/CORE" -DHAVE_UTF8 -DHAVE_BLANK LibXML.c In file included from LibXML.xs:32: /usr/include/libxml2/libxml/DOCBparser.h:22:2: warning: #warning "The DOCBparser module has been deprecated in libxml2-2.6.0" LibXML.xs: In function 'XS_XML__LibXML__parse_string': LibXML.xs:953: warning: pointer targets in assignment differ in signedness LibXML.xs: In function 'XS_XML__LibXML__Node_toStringC14N': LibXML.xs:4369: warning: pointer targets in passing argument 1 of 'xmlStrdup' differ in signedness LibXML.xs:4371: warning: pointer targets in passing argument 1 of 'xmlStrdup' differ in signedness cc -c -I/usr/include/libxml2 -g -pipe -fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -I/usr/local/include -Os -DVERSION=\"1.58\" -DXS_VERSION=\"1.58\" "-I/System/Library/Perl/5.8.6/darwin-thread-multi-2level/CORE" -DHAVE_UTF8 -DHAVE_BLANK dom.c dom.c: In function 'domName': dom.c:415: warning: pointer targets in assignment differ in signedness dom.c:419: warning: pointer targets in assignment differ in signedness cc -c -I/usr/include/libxml2 -g -pipe -fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -I/usr/local/include -Os -DVERSION=\"1.58\" -DXS_VERSION=\"1.58\" "-I/System/Library/Perl/5.8.6/darwin-thread-multi-2level/CORE" -DHAVE_UTF8 -DHAVE_BLANK perl-libxml-mm.c perl-libxml-mm.c: In function 'PmmFastDecodeString': perl-libxml-mm.c:815: warning: pointer targets in passing argument 1 of 'xmlCharStrndup' differ in signedness cc -c -I/usr/include/libxml2 -g -pipe -fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -I/usr/local/include -Os -DVERSION=\"1.58\" -DXS_VERSION=\"1.58\" "-I/System/Library/Perl/5.8.6/darwin-thread-multi-2level/CORE" -DHAVE_UTF8 -DHAVE_BLANK perl-libxml-sax.c perl-libxml-sax.c: In function 'PmmGenAttributeHashSV': perl-libxml-sax.c:470: warning: pointer targets in passing argument 1 of '_C2Sv' differ in signedness perl-libxml-sax.c:474: warning: pointer targets in passing argument 1 of '_C2Sv' differ in signedness cc -c -I/usr/include/libxml2 -g -pipe -fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -I/usr/local/include -Os -DVERSION=\"1.58\" -DXS_VERSION=\"1.58\" "-I/System/Library/Perl/5.8.6/darwin-thread-multi-2level/CORE" -DHAVE_UTF8 -DHAVE_BLANK xpath.c Running Mkbootstrap for XML::LibXML () chmod 644 LibXML.bs rm -f blib/arch/auto/XML/LibXML/LibXML.bundle LD_RUN_PATH="/usr/lib" env MACOSX_DEPLOYMENT_TARGET=10.3 cc -bundle -undefined dynamic_lookup -L/usr/local/lib LibXML.o dom.o perl-libxml-mm.o perl-libxml-sax.o xpath.o -o blib/arch/auto/XML/LibXML/LibXML.bundle -L/usr/lib -lxml2 -lz -lpthread -liconv -lm chmod 755 blib/arch/auto/XML/LibXML/LibXML.bundle cp LibXML.bs blib/arch/auto/XML/LibXML/LibXML.bs chmod 644 blib/arch/auto/XML/LibXML/LibXML.bs Manifying blib/man3/XML::LibXML::Number.3pm Manifying blib/man3/XML::LibXML::DOM.3pm Manifying blib/man3/XML::LibXML::Node.3pm Manifying blib/man3/XML::LibXML::Literal.3pm Manifying blib/man3/XML::LibXML::Parser.3pm Manifying blib/man3/XML::LibXML::DocumentFragment.3pm Manifying blib/man3/XML::LibXML::Element.3pm Manifying blib/man3/XML::LibXML::SAX::Builder.3pm Manifying blib/man3/XML::LibXML::Namespace.3pm Manifying blib/man3/XML::LibXML::Document.3pm Manifying blib/man3/XML::LibXML::Attr.3pm Manifying blib/man3/XML::LibXML::SAX::Generator.3pm Manifying blib/man3/XML::LibXML::CDATASection.3pm Manifying blib/man3/XML::LibXML::SAX.3pm Manifying blib/man3/XML::LibXML.3pm Manifying blib/man3/XML::LibXML::Text.3pm Manifying blib/man3/XML::LibXML::Boolean.3pm Manifying blib/man3/XML::LibXML::PI.3pm Manifying blib/man3/XML::LibXML::NodeList.3pm Manifying blib/man3/XML::LibXML::Dtd.3pm Manifying blib/man3/XML::LibXML::Comment.3pm Nachtblauer-Tower:/Volumes/PerlStuff/XML-LibXML-1.58 beyerjoerg$
Download (untitled) / with headers
text/plain 2.4k
Ok, I understand all these warnings look rather ugly, but in fact, they are all quite harmless. From your log, it is apparent that make runs just fine and that the code compiles on your platform, contradicting your claim it doesn't. If you have problems running the software, then it has nothing to do with these warnings. I'd like to help, but I don't really see any problem here. Either be more specific (demonstrate what you claim, e.g. that something related to XM:::LibXML does not build on your system). Show quoted text
> (1) Warning while running 'perl makefile.PL' > > "running xml2-config...untested > WARNING!
... Perfectly ok, last release is some years old and at that time, current version of libxml2 was not available for tests. Since in past there were some versions of libxml2 that broke compatibility with XML::LibXML, there is this safety INFORMATIVE warning. I agree the wording could be less alerting. Anyway, a future maintanence release will make them go away. In the meantime, just ignore them. Show quoted text
> Well, the Readme does not say something helpfull... It's out of
date. no doubt. As are newspapers from 2004. Show quoted text
> (2) "Signedness warnings" during 'make'
ignore them, they are simply matter of coding style rather than bugs or portability issues. Show quoted text
> (3) Warning of deprecated DOCBparser
Yes, your version of libxml2 does not support docbook parser. This is also perfectly ok. Show quoted text
> Just for the record -- this problem is not only Apple/OS X related, > there are some general > problems with XML::LibXML and related modules in their current
states. I don't see a real problem, though. Show quoted text
> Perl modules are > expected to be platform independent, and these ones aren't.
What makes you think so? Anything to back up this claim? Show quoted text
> I contacted the author of XML::LibXML and related modules, Christian > Glahn, a week ago and > still hope to get an answer.
With all due respect, as far as I can tell, all your recent tickets are just rants not bugs that would require much attention by the maintainers. Show quoted text
> But since this bug list grows while there is no visible development > or maintenance of > XML::LibXML since two years, I think we're all out of luck.
I agree with you at the point that there has been no public activitiy by Christian nor me regarding these modules. I believe, can always step up and offer your skills. Only in your case the other hand, I beg you don't until you can distinguish a warning from a bugs. Sorry for not being quite polite.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.