This queue is for tickets about the XML-Simple CPAN distribution.

Report information
The Basics
Id:
18393
Status:
rejected
Priority:
Low/Low
Queue:

People
Owner:
grantm [...] cpan.org
Requestors:
donk71 [...] gmail.com
Cc:
AdminCc:

BugTracker
Severity:
Important
Broken in:
2.14
Fixed in:
(no value)



Subject: CDATA bug
XML Simple (2.14) does not parse CDATA sections correctly when run on WinXP SP2 under ActivePerl (5.8.8 Build 816). CDATA sections get appended with a right-arrow (">") for some reason. This does not occur under RHEL4 using Perl 5.8.5. The attached test script demonstrates the behavior. Linux output: $VAR1 = 'filfthflarnfilfth'; Windows output: $VAR1 = 'filfthflarnfilfth>';
Subject: testr.pl
#!/usr/bin/perl use XML::Simple; use Data::Dumper; $pxml = new XML::Simple; $testmsg = "<?xml version=\"1.0\" encoding=\"UTF-8\"?><testmsg><![CDATA[filfthflarnfilfth]]></testmsg>"; $comm = $pxml->XMLin($testmsg); print Dumper($comm);
From: donk71@gmail.com
Please disregard, this is an issue with SAX 0.13. Sorry! On Mon Mar 27 13:07:16 2006, guest wrote:
Show quoted text
> XML Simple (2.14) does not parse CDATA sections correctly when run on > WinXP SP2 under ActivePerl (5.8.8 Build 816). CDATA sections get > appended with a right-arrow (">") for some reason. This does not occur > under RHEL4 using Perl 5.8.5. The attached test script demonstrates the > behavior. > > Linux output: > > $VAR1 = 'filfthflarnfilfth'; > > Windows output: > > $VAR1 = 'filfthflarnfilfth>';


This service runs on Request Tracker, is sponsored by The Perl Foundation, and maintained by Best Practical Solutions.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.