Skip Menu |
 

This queue is for tickets about the Brackup CPAN distribution.

Report information
The Basics
Id: 18312
Status: open
Priority: 0/
Queue: Brackup

People
Owner: Nobody in particular
Requestors: adamk [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Important
Broken in: (no value)
Fixed in: (no value)



Subject: Don't assume that gpg is installed and available
Download (untitled) / with headers
text/plain 427b
You currently use gpg pretty much blindly from what I can see. What you probably should do is to at the very least put a check into your Makefile.PL to confirm in advance that gpg is installed and tell the installer to go and install gpg first (assuming GPG is compulsory). The system call to use gpg looks relatively clean, but you might want to look into IPC::Run3, which is basically a cross-platform equivalent of system.
Download (untitled) / with headers
text/plain 546b
I don't want to require gpg. If you don't have it, then you can't do encrypted backups. But no reason to say that users can't do regular backups without it. As for system vs. Run3: I don't want to add a dependency for Unix users, where I use system() just fine. But if you can get PAR to work (last time I checked all the docs were offline because of a disk crash), then I'd love a patch to add Windows support if a Windows binary could be made. In that case, optionally requiring IPC::Run3 on $^O eq "Win32" or whatever would be fine.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.