Skip Menu |
 

This queue is for tickets about the Brackup CPAN distribution.

Report information
The Basics
Id: 18309
Status: open
Priority: 0/
Queue: Brackup

People
Owner: Nobody in particular
Requestors: adamk [...] cpan.org
Cc:
AdminCc:

Bug Information
Severity: Critical
Broken in: (no value)
Fixed in: (no value)



Subject: Missing dependencies.
Download (untitled) / with headers
text/plain 1.7k
OK, so you've got three deps listed in the makefile, and in order to install this thing, we'll need a few more. Perl version dependency is at least 5.6 (from "use warnings"), you don't actually mention it, so probably want to add either an explicit thing in the Makefile.PL or perhaps add a use 5.006 to brackup. For a more thorough check, try downloading "perlver" from CPAN (comes with Perl::MinimumVersion) and run it to make sure you haven't missed anything. Even with a default of 5.005, it can be useful to mention via an any-version "0" dep the core modules you use, in case you change the perl version back to 5.005 or something. Some of these are more necesary than others. Carp Getopt::Long Cwd File::Temp File::stat Fcntl File::Find Or at the least check when these modules went into the core and make sure you have a any-version dep for anything that got merged newer than 5.004. This URL might help. http://www.twoshortplanks.com/modulecorelist/ You also really want to go read through the Changes file for DBD::SQLite and pick an explicit version for that particular dependency, since it matter more than some others. And of course you haven't got a dependency on Net::Amazon::S3 :) This is going to matter a lot more as you add more targets... you really have to add either proper dependencies for all the targets that you core-ify (which might be a reasonable option in your case for a while), or you move to using Module::Pluggable for your targets, and upload the target modules seperately. Or more likely, use Module::Pluggable, put the most common and light-dependency ones into the core, and upload the ones with more ominous dependencies as seperate distributions. And that about covers dependency issues. :)
Download (untitled) / with headers
text/plain 214b
I don't want to bloat the core dependencies, so I'll distribute the S3 target separately. Whether I use Module::Pluggable is another issue: I don't think it buys me a ton in this case. Keeping this ticket open.


This service is sponsored and maintained by Best Practical Solutions and runs on Perl.org infrastructure.

Please report any issues with rt.cpan.org to rt-cpan-admin@bestpractical.com.